Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Compiling a Plugin

Re: Compiling a Plugin

From: neoAKiRAz <neoakiraz_at_gmail.com>
Date: Sat, 17 Mar 2007 20:44:04 -0300

Yes, and just in case I deleted my previous build folders in /rockbox and:

svn update
mkdir build-sim
cd build-sim
../tools/configure

I selected 50 for Sansa and then S to build the simulator. Then 'make'.
It took 20 minutes in my P4 2.4Ghz (cygwin). Then 'make install', just a
couple of minutes. Then I run it and it worked ok.
So I made a change to my_plugin.c and then a 'make rocks'. It took 10
minutes, and the output was:

make[1]: `rdf2binary' is up to date.
make[1]: `convbdf' is up to date.
make[1]: `bmp2rb' is up to date.
make[1]: `codepages' is up to date.
make[1]: `scramble' is up to date.
MAKE in bitmaps/mono
make[2]: Nothing to be done for `all'.
MAKE in bitmaps/native
make[2]: Nothing to be done for `all'.
make[2]: Nothing to be done for `all'.
MAKE in libmad
make[3]: Nothing to be done for `all'.
MAKE in liba52
make[3]: Nothing to be done for `all'.
MAKE in libffmpegFLAC
make[3]: Nothing to be done for `all'.
MAKE in Tremor
make[3]: Nothing to be done for `all'.
MAKE in libwavpack
make[3]: Nothing to be done for `all'.
MAKE in libmusepack
make[3]: Nothing to be done for `all'.
MAKE in libalac
make[3]: Nothing to be done for `all'.
MAKE in libfaad
make[3]: Nothing to be done for `all'.
MAKE in libm4a
make[3]: Nothing to be done for `all'.
MAKE in libspeex
make[3]: Nothing to be done for `all'.
CC codec_crt0.c
LD vorbis.codec
LD mpa.codec
LD flac.codec
LD wav.codec
LD a52.codec
LD mpc.codec
LD wavpack.codec
LD alac.codec
LD aac.codec
LD shorten.codec
LD aiff.codec
LD speex.codec
LD sid.codec
LD adx.codec
LD nsf.codec
LD spc.codec
rm /home/rockbox/build-sim/apps/codecs/codec_crt0.o
make[2]: Nothing to be done for `all'.
MAKE in plugins/bitmaps/mono
make[3]: Nothing to be done for `all'.
MAKE in plugins/bitmaps/native
make[3]: Nothing to be done for `all'.
MAKE in plugins/bitmaps/mono
make[3]: Nothing to be done for `all'.
MAKE in plugins/bitmaps/native
make[3]: Nothing to be done for `all'.
create credits.raw
CC credits.c
LD credits.rock
CC my_plugin.c
LD my_plugin.rock
MAKE in rockboy
make[3]: Nothing to be done for `all'.
MAKE in chessbox
make[3]: Nothing to be done for `all'.
MAKE in sudoku
make[3]: Nothing to be done for `all'.
MAKE in zxbox
make[3]: Nothing to be done for `all'.
MAKE in pacbox
make[3]: Nothing to be done for `all'.
MAKE in doom
make[3]: Nothing to be done for `all'.
MAKE in mpegplayer
make[3]: Nothing to be done for `all'.

Then 'make install' (couple more mintues) and then tried it, and it
worked. But waiting 10 minutes after every little change is quite
tedious. What can be wrong? I hope you can help me. Thx!
Received on 2007-03-18


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa