Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Sansa radio driver (AS5314 help

Re: Sansa radio driver (AS5314 help

From: Ivan Zupan <zivan56_at_iwdstudio.com>
Date: Wed, 16 May 2007 13:26:25 -0800

Great news folks. Very loud audio!
The secret was the stuff involving address 0x70000084 and 0x70000080!
Now to work on the algorithms for tuning and getting volume control to
work with the line1 in (very loud even if gain is very low)
Btw, the settings below actually mute line1 in while tuning, so it is a
bit misleading :)
Thanks for the help with figuring this out.

Antonius Hellmann wrote:
> If you can hear any sound, then I would assume, that the device is
> working.
> So nothing more to be done with the radio init/powerup.
> I bet, that the audio configuration is not correct yet.
> In the emu I found following AS3514 init sequence after entering the
> radio menu
> and after setting up the tuner:
> AUDIOSET1 4e
> 70000084 |= 1 <<<<< don't know, wether this is radio related
> 70000080 |= 4 <<<<< don't know, wether this is radio related
> HPH_OUT_L e0
> HPH_OUT_L 6b
> HPH_OUT_R eb
> LINE_IN1_L df
> LINE_IN1_R df
> AUDIOSET1 4a
> AUDIOSET1 4e
> LINE_IN1_L df
> LINE_IN1_R df
>
> And regarding your other question:
> 69ddd55 0000e8f4 CPU ???????? 70000020 R4-40000000
> 69ddd57 0000e8fc CPU ???????? 70000020 W4-40000000
> I added the comment after looking at the assembler code at addr 0000e8f4.
> The cpu reads a value from 0x70000020, bics bit11 and stores the
> result. Nothing wrong here.
Received on 2007-05-16


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa