Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: strange error when trying to build voice

Re: strange error when trying to build voice

From: alex wallis <alexwallis646_at_googlemail.com>
Date: Mon, 9 Feb 2009 21:50:24 -0000

> alex wallis wrote:
>> Hi list.
>
>
>> The error when I try to build a voice that comes up is as follows
>> Bareword "CMD_OUT" not allowed while "strict subs" in use at
>> /home/Administrator
>> /rockbox/tools/voice.pl line 96.
>> BEGIN not safe after errors--compilation aborted at
>> /home/Administrator/rockbox/
>> tools/voice.pl line 414.
>> make: *** [voice] Error 255
>>
>
> Have a look at r18102, which fixed this issue (half a year ago). Next time
> you have issues running old code, please check if it's been fixed since.

Hi.
I am trying to get the 3.1 branch of rb code, the only reason I was trying
to work with 17883 was that was the only other revision prior to the 3.1
branch which I had working patches for.
But no matter what the command is I use I still get the message at the end
of checkout checked out whatever the current revision number is.
Checked out revision 19957. for example.

I have tried using the following commands to try to get branch 3.1, could
you please advise where I am going wrong?

svn co svn://svn.rockbox.org/rockbox/tags/v3_1 rockbox
and
svn co svn://svn.rockbox.org/rockbox/branches/v3_1 rockbox

I think something must be going wrong somewhere as the patches I am using
have been synced with the 3.1 branch and yet for me some of them won't
apply, but sdoyon says they apply fine with his 3.1 checkout.
Received on 2009-02-09


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa