dev builds
themes manual
device status forums
mailing lists
IRC bugs
dev guide

Rockbox mail archive

Subject: Re: bieber: r27137 - in trunk/utils/themeeditor: . findreplace gui

Re: bieber: r27137 - in trunk/utils/themeeditor: . findreplace gui

From: Dominik Riebeling <>
Date: Sat, 26 Jun 2010 15:50:15 +0200

On Sat, Jun 26, 2010 at 9:59 AM, <> wrote:
> Date: 2010-06-26 09:59:23 +0200 (Sat, 26 Jun 2010)
> New Revision: 27137
> Log Message:
> Theme Editor: Added an edit menu with a find/replace function (copied from an LGPL library)
> + * This file has been copied from Lorenzo Bettini, with minor modifications
> + * made available under the LGPL version 3, as the original file was licensed

As far as I understand this is a problem: while most Rockbox code and
also the Theme Editor is GPLv2+ that imported code is LGPL3. Unless
that code does allow using it under the terms of the LGPLv2 (or
LGPLv2.1) it is incompatible with the Rockbox license according to (unless we
switch to GPLv3 for at least the Theme Editor).

Is the imported code from ? If
yes it's definitely (and unfortunately) LGPLv3. Please correct me if
I'm wrong on this topic.

 - Dominik
Received on 2010-06-26

Page was last modified "Jan 10 2012" The Rockbox Crew