Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: [Theme Editor] Weekly Status Report #7

Re: [Theme Editor] Weekly Status Report #7

From: Dominik Riebeling <dominik.riebeling_at_gmail.com>
Date: Sun, 4 Jul 2010 08:28:55 +0200

On Sun, Jul 4, 2010 at 7:38 AM, Mike Giacomelli <giac2000_at_hotmail.com> wrote:
> As Rafaël says we're a GPLv2+ project, so you can link LGPLv3 code against
> rockbox.  The resulting binary is GPLv3.  Unless you are also including
> additional GPLv2 only code in the editor, I don't see any reason to prefer
> any particular GPL version for your project.

I've already wrote about that issue to the corresponding commit (why
didn't you guys chime in back then?) and from my understanding it's
not just the binary. As far as I understand the FAQ (I've checked
http://www.gnu.org/licenses/gpl-faq.html#AllCompatibility which seems
to be the same table) using LGPLv3 code means that we would also need
to convert the *source* code to GPLv3, something I'm not sure if we
really want to do. I am not a lawyer, so can someone clarify this for
me? The "OK if you upgrade and convert to GPLv3" pretty much reads to
me that you need to change the source code license so the Theme Editor
had to be GPLv3 if it used LGPLv3 code.

 - Dominik
Received on 2010-07-04


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa