Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: [New WMA Codecs] Progress Report #6

Re: [New WMA Codecs] Progress Report #6

From: Dave Hooper <dave_at_beermex.com>
Date: Mon, 12 Jul 2010 10:41:49 +0100

It sounds like either the wmapro mdct has additional pre/post steps compared
to codeclib (or alternatively is lacking codeclibs pre/post steps and doing
those steps elsewhere), or else wmapro has different
expectations/assumptions compared to codeclib (e.g. codeclib has strict
requirements over input output buffers not overlapping etc). I'd be
surprised if codeclib imdct has a bug, as such, that only affects decoding
wmapro frames.

On 11 Jul 2010 18:33, "Mohamed Tarek" <mtarek16_at_gmail.com> wrote:

On Sun, Jul 11, 2010 at 2:51 PM, Mohamed Tarek <mtarek16_at_gmail.com> wrote:
>
>
> Yes I might need to...

I tried that and got the exact same faulty output. I tried copying the fixed
point coefficients into the floating point ones passing those to the float
imdct and then copying back the float coeffs into the fixed coeffs just
after, and the sound quality was perfect, so it seems it's actually a
problem with the mdct. (both codeclib's and libwmapro's)

>
> Also, there seems to be something wrong with the patch, I'll prepare
another one tonight.
>

I take that back. The patch applied and compiled cleanly against a fresh
checkout.

-- 
MT
Received on 2010-07-12

Page was last modified "Jan 10 2012" The Rockbox Crew
aaa