dev builds
themes manual
device status forums
mailing lists
IRC bugs
dev guide

Rockbox mail archive

Subject: Re: Upgrading coldfire gcc

Re: Upgrading coldfire gcc

From: Thomas Martitz <>
Date: Mon, 27 Dec 2010 19:38:40 +0100

On 27.12.2010 12:59, Nils Wallménius wrote:
> There are some things i'm not sure about though.
> Should we keep the old toolchain around? And if so, should
> be able to select which version to build and should
> configure deal with the different versons (they need different command
> line args). I think that for point releases of the 3.7 branch we can
> and should keep the old toolchain and drop support for it from trunk.
> If we want to keep the old toolchain the prefix scheme in
> needs adjustment as the way it works now only allows one
> toolchain per target and abi.

I don't think we need to keep the old toolchain. We can do the switch
after the next point release (if there is going to be one), as I doubt
we'll do another.

Best regards.
Received on 2010-12-27

Page was last modified "Jan 10 2012" The Rockbox Crew