dev builds
themes manual
device status forums
mailing lists
IRC bugs
dev guide

Rockbox mail archive

Subject: Re: Upgrading coldfire gcc

Re: Upgrading coldfire gcc

From: Nils Wallménius <>
Date: Wed, 12 Jan 2011 13:49:49 +0100

One issue turned up with building the toolchain on cygwin which was
solved. Building gcc 4.5 requires a c++ compiler so make sure you have
one installed, the patch was also updated (in FS#7832).
I also spotted a warning in the coldfire bootloaders but i can't test
if my patch doesn't break them as i only have the iriver h300 for
which the svn bootloader doesn't work anyway and it isn't recoverable
without external hardware that i don't have.
I built bootloaders for the iaudio m5 and x5 as these should be easy
to recover from broken bootloaders. It would be great if someone could
please test them:

Received on 2011-01-12

Page was last modified "Jan 10 2012" The Rockbox Crew