Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: GSoC/Buflib: Weekly report #2

Re: GSoC/Buflib: Weekly report #2

From: Al Le <al.le_at_gmx.de>
Date: Tue, 07 Jun 2011 21:53:17 +0200

On 07.06.2011 18:31, Thomas Martitz wrote:
> But I also sent this mail to make it clear that the names are not fixed
> by now. I think the core_ prefix is less than ideal but I couldn't up
> with something better yet (mm_ perhaps?).

I assume buf_ (or something with "buf" inside) can't be used? Since then
you'd surely consider it.

Is there some convention regarding the return values of the alloc
functions? I.e. what value is returned if the allocation failed? A
negative value?

There is a typo in the first comment: it should read "these", not
"this". Also, many comments start with an imperative ("Allocate....")
and end in the 3rd person ("Returns ....").

Just my questions / notions from a short look.
Received on 2011-06-07


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa