Rockbox.org home
release
dev builds
extras
themes manual
wiki
device status forums
mailing lists
IRC bugs
patches
dev guide



Rockbox mail archive

Subject: Re: Working towards skin engine 2.0 (includes RFC on code!)

Re: Working towards skin engine 2.0 (includes RFC on code!)

From: Thomas Martitz <kugel_at_rockbox.org>
Date: Tue, 08 Nov 2011 14:48:03 +0100

Am 08.11.2011 14:17, schrieb Jonathan Gordon:

> I honestly didnt think it would be this simple! Attached is the
> changes removing all dynamic pointers from the skin engine!

Very nice to see it can be done! Good work.

> I'm not entirely sure what to do about the conversion macros. I am
> going to keep the OFFSETTYPE() one (though open to a better name)
> because it is helpful).
>

I disagree. It's introducing an awkward pattern (macros which
intentionally do nothing, but look like they would). Comments are for
this very purpose.

> (though I
> don't think changing them to functions is beneficial).

Well, they _look_ nicer. Static inline maybe?

IMO the skin_buffer should left out if it's really passed to each macro
call. The parameter can be added later when it's meaningful, presumably
in a later patch to use a per-skin buffer. Each call of the macro needs
to be changed anyway.

Best regards.
Received on 2011-11-08


Page was last modified "Jan 10 2012" The Rockbox Crew
aaa