Rockbox mail archive
Subject: Re: Working towards skin engine 2.0 (includes RFC on code!)
Re: Working towards skin engine 2.0 (includes RFC on code!)
On 14 November 2011 01:09, Frank Gevaerts <frank_at_gevaerts.be> wrote:
> On Wed, Nov 09, 2011 at 12:17:02AM +1100, Jonathan Gordon wrote:
>> I'm not entirely sure what to do about the conversion macros. I am
>> going to keep the OFFSETTYPE() one (though open to a better name)
>> because it is helpful).
> Is it really? I can't say I'm convinced,
> If someone could come up with a way to make OFFSETTYPE() actually *do*
> something (a clever way to do type checking, maybe), I'd agree. The way
> it stands now it's just as easy to overlook as a comment when changing
> things, and *nothing* will complain (the thing given there doesn't even
> have to be a valid type...).
At a minimum it is needed so the same maasive rework isnt needed in
the theme editor. And yes, I've found it ery useful during development
to know what exatly is being pointed to. I agree it would be 100x
better if the compiler could actually warn if the type isnt correct
but thats not really doable.
Received on 2011-11-13
Page was last modified "Jan 10 2012" The Rockbox Crew