Rockbox

Tasklist

FS#11339 - Volume is turned up to the maximum when the battery level gets very low

Attached to Project: Rockbox
Opened by Max Bargiel (dorenthas) - Monday, 31 May 2010, 18:26 GMT
Last edited by Bertrik Sikken (bertrik) - Friday, 05 November 2010, 09:33 GMT
Task Type Bugs
Category Battery/Charging
Status Waiting on Customer
Assigned To No-one
Operating System iriver H10
Severity Low
Priority Normal
Reported Version Release 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

When the battery is nearly empty and the iriver H10 is about to shutdown, the volume sometimes suddenly increases progressively, as if the volume UP button was pressed and held down, all the way up to the maximum.

This has happened to me about 3-4 times so far. Pressing the volume DOWN button somewhat counters this bug, but only for as long as the DOWN button is used - the volume keeps increasing.

This occurs with Rockbox Release 3.5 (not 3.4 as the Report Version field of the ticket says).
This task depends upon

Comment by Max Bargiel (dorenthas) - Monday, 31 May 2010, 18:27 GMT
I wasn't sure of the category - I put Battery/Charging because the only trigger I found was the battery going empty.
Comment by Bertrik Sikken (bertrik) - Saturday, 16 October 2010, 16:05 GMT
Looking at the h10 button driver, I can imagine that this happens when rockbox thinks that there is a remote control attached when the remote control voltage drops below value 0x3FF (1023), due to low battery. Voltage values 720 to 1023 are interpreted as the "volume up" button.

When this happens, can you have a look at the debug menu and see if there's a menu showing the value for "ADC_REMOTE"? Please let us know the value with no keys pressed and the value with the "volume up" button pressed (if you have a remote).

A possible fix would be to lower the voltage where a remote button press is detected.
Comment by Max Bargiel (dorenthas) - Thursday, 21 October 2010, 18:00 GMT
I'll see if I can provide you with the requested information, it may take a couple days before I have time for that. Then again, I don't think there's any rush... :) (Note: I don't use any kind of remote control with the device.)
Comment by klovos (klovos) - Friday, 30 September 2011, 20:37 GMT
I think a temporary solution for that would be to add a setting to enable/disable the remote control... This way, rockbox doesn't think it's there.

When you say look at the debug menu, you mean there's supposed to be a menu inside debug called "ADC_REMOTE"?
Comment by klovos (klovos) - Saturday, 01 October 2011, 18:14 GMT
I commented all the /* remote buttons */ section in button-h10.c and the bug stopped occuring.

Loading...