Rockbox

Tasklist

FS#11617 - Cannot reset the original hotkey behaviour in WPS

Attached to Project: Rockbox
Opened by Rosso Maltese (asettico) - Thursday, 09 September 2010, 16:02 GMT
Last edited by Michael Chicoine (mc2739) - Wednesday, 17 November 2010, 13:40 GMT
Task Type Bugs
Category Settings
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Referred to r28030.

After to be changed the behaviour of the hotkey in WPS, it's not possible to reset it to the original one (show folder of current track).
This task depends upon

Closed by  Michael Chicoine (mc2739)
Wednesday, 17 November 2010, 13:40 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Closed at request of originator
Comment by Thomas Martitz (kugel.) - Friday, 10 September 2010, 22:17 GMT
The default hotkey action should be "show current playlist". What player are you refering to?
Comment by Rosso Maltese (asettico) - Saturday, 11 September 2010, 13:32 GMT
ipod video 5.5g 64 MB.
I remember that before the introduction of this feature, pressing select (the central button) I saw the content of the folder containing the current track.
The same behaviour when in WPS you press Menu and then File.
Comment by Thomas Martitz (kugel.) - Saturday, 11 September 2010, 14:26 GMT
Select shouldn't be the hotkey button. According to http://download.rockbox.org/daily/manual/rockbox-ipodvideo/rockbox-buildch4.html#x7-500004.3 it's select+play.
Comment by Rosso Maltese (asettico) - Saturday, 11 September 2010, 14:41 GMT
In this case, it's a real bug: the behaviour of Select and Select+Play is the same.
Comment by Jeffrey Goode (Blue_Dude) - Monday, 13 September 2010, 00:47 GMT
This is a known flaw in the way the ipod keymap is coded. I tried to fix it a few months ago in r25665, but there was significant backlash, so it was reverted in r25668. IIRC the backlash was because I committed without sufficient testing. However, the hotkey setting mechanism has changed since then and the original objections may no longer apply.

My suggestion is to change the keymap code for ACTION_TREE_HOTKEY and ACTION_WPS_HOTKEY to either BUTTON_SELECT|BUTTON_PLAY, BUTTON_SELECT or BUTTON_SELECT|BUTTON_PLAY, BUTTON_PLAY (or both) and try it out for a while to see if that works for you. If it does, suggest a commit on the IRC channel.
Comment by Rosso Maltese (asettico) - Tuesday, 16 November 2010, 17:29 GMT
Ehm... I'm sorry, this is not a bug (probably this is due to a patch that interferes with the key map).
Please, close it as not a bug.

Loading...