Rockbox

Tasklist

FS#12071 - Database build on iPod video 60 GB hangs

Attached to Project: Rockbox
Opened by Jeff (jpudlo) - Sunday, 17 April 2011, 18:48 GMT
Last edited by MichaelGiacomelli (saratoga) - Sunday, 15 May 2011, 21:30 GMT
Task Type Bugs
Category Database
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Release 3.8.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Initial database build still hangs upon initial scan. Exact same error that existed in build 3.8 with the same symptoms.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Sunday, 15 May 2011, 21:30 GMT
Reason for closing:  Fixed
Comment by MichaelGiacomelli (saratoga) - Sunday, 17 April 2011, 23:25 GMT
Could you:

1) First confirm that your file system has no errors
2) Enable database logging (System > Debug > Metadata log)
3) Check the metadata log created in the root of your file system and remove whatever file crashed the parser and see if that fixes the problem

If 3 fixes it, please upload the file.
Comment by Jeff (jpudlo) - Friday, 22 April 2011, 18:01 GMT
Yes, I have tried these tasks. Additionally, I deleted ALL Rockbox music (wma files) and had the same error.
Comment by MichaelGiacomelli (saratoga) - Friday, 22 April 2011, 18:03 GMT
Can you format the device, add one of these files:

http://download.rockbox.org/test_files/

And confirm that it works. Then add your files back, enable logging, and try to figure which one crashes the devices.
Comment by Jeff (jpudlo) - Saturday, 23 April 2011, 14:45 GMT
Totally appreciate the help and was hoping you could elaborate the logic-moving/formatting/reloading/debugging to find a file that works perfectly on ver 3.7.1? Any chance you could expand before I redo the device? Sorry to question as I really appreciate your help and your efforts!
Comment by MichaelGiacomelli (saratoga) - Saturday, 23 April 2011, 18:40 GMT
If you just want help fixing your player, its probably better to post in the forums. The tracker is really more for bug reports and testing then support.
Comment by Jeff (jpudlo) - Sunday, 08 May 2011, 17:30 GMT
Michael,

Thanks for the follow up and sorry for the delay. Just to be clear, I have deleted all music content. Reformatted and restored with Apple firmware. Performed a complete disk scan sector by sector, then reinstalled Rockbox 4.8.1 and have the exact hanging error when the database tries to initialize. There are NO music files on the player at this point. I added one of the files you linked to and have the same hanging error during database initialization To me, this seems to clearly indicate the problem is a bug in the new version as the previous version works just fine. Please let me know if I am in error in my logic and thanks for your help!

Jeff
Comment by Jeff (jpudlo) - Sunday, 15 May 2011, 16:50 GMT
VICTORY! Ran the 6 variable experiment but was able to finally resolve the issue. I changed data cables; did a complete uninstall; reformat; set up new Apple firmware; reinstall with new 1.2.10 installer. All is good. It seems either the data cable, the new format, or the new installer seems to have corrected the issue. Thx for the help!

Loading...