Rockbox

Tasklist

FS#12300 - MPEG Player - Data Abort if any button is pressed during playback

Attached to Project: Rockbox
Opened by UNHchabo (UNHchabo) - Thursday, 29 September 2011, 05:34 GMT
Last edited by Michael Sevakis (MikeS) - Monday, 31 October 2011, 11:59 GMT
Task Type Bugs
Category Video
Status Closed
Assigned To No-one
Operating System SW-codec
Severity Low
Priority Normal
Reported Version Rbutil SVN
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm running Rockbox on a Sansa e250, with version r30618-110929.

After starting up a video from the file browser, pressing any button causes the player to lockup and show the error message "Data abort at 0005ff58 (0)". The only exception is the power button, which when pressed will bring me back to the file browser.

I have to hold down the power button and do a hard shutdown in order to restart the player.

I can reproduce this with other videos as well, but I tested with "elephantsdream-q6-224x176-469kbps.mpg".

I can reproduce this issue by putting the video on either the internal storage, or my SD card.

This behavior does not seem to occur in 3.9.1, but the bug has been in place for at least a day.
This task depends upon

Closed by  Michael Sevakis (MikeS)
Monday, 31 October 2011, 11:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  Presumably fixed. I'm not seeing trouble on any device in latest SVN.
Comment by Michael Sevakis (MikeS) - Thursday, 29 September 2011, 18:50 GMT
Yes, that's definitely a new feature. Tried on Gigabeat S with similar results. I saw corruption in the fonts one time in the OSD just before it crashed.
Comment by Michael Sevakis (MikeS) - Thursday, 29 September 2011, 18:57 GMT
Looks like the prophesies of the buflib beast are coming to pass. There's an antipattern present in the entire design that's going to be very difficult to repair.
Comment by Michael Sevakis (MikeS) - Friday, 30 September 2011, 21:30 GMT
I was trying on e200 and it wasn't crashing but no text was being drawn in the OSD.
Comment by UNHchabo (UNHchabo) - Saturday, 01 October 2011, 08:52 GMT
I can still reproduce the original bug in r30623.

I noticed that sometimes when it froze with some videos I transcoded with VLC, the video still took up most of the screen, but the "Data abort" message was still being shown on part of the screen. The "ElephantsDream" video would show the "Data abort" message on the full screen, though.

Let me know if there's any other information that would help.
Comment by Joe Abbott (fretless) - Sunday, 02 October 2011, 20:45 GMT
I've had this same problem since upgrading to r30619-110929 on e250. It only seems to appear when I have music paused or music queued up
with 'Resume Playback' turned on in Settings-General Settings-System-Start Screen menu or have just finished playing music. Tried selecting
'Main Menu' instead and problem only occurred while playing video after playing music. Playing video just after power-up but before playing
any music doesn't seem to exhibit problem.
Comment by Michael Sevakis (MikeS) - Sunday, 30 October 2011, 11:32 GMT
I tried r30864 on my e260v1 and text display is now working. Does this seem resolved now?

Loading...