Rockbox

Tasklist

FS#12425 - Sansa Clip+ freezes up when selecting any theme file (wps, fms, sbs)

Attached to Project: Rockbox
Opened by James Hunt (james_hunt) - Friday, 02 December 2011, 22:46 GMT
Last edited by Jonathan Gordon (jdgordon) - Thursday, 22 December 2011, 12:28 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System Sansa AMSv2
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Sansa Clip+ freezes up when selecting any theme file (wps, fms, sbs). Helps only hard reset.
Bug is present in 31107 rev, and there's no in 31100.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Thursday, 22 December 2011, 12:28 GMT
Reason for closing:  Fixed
Comment by James Hunt (james_hunt) - Friday, 02 December 2011, 23:14 GMT
UPD: Bug doesn't reproduce in UiSimulator.
Comment by James Hunt (james_hunt) - Saturday, 03 December 2011, 00:01 GMT
UPD2: On simulator bug can reproduced too, it just quits.

Important note: simulator immeditanly quits if theme (not only *.sbs, *.wps too) that worked fine before exists in config.cfg. But real player boots normal with problem theme and freezes up only when try to change them.

How reproduce: select attached theme for statusbar (seems buggy for now, before it worked fine), reboot player, select any (wps, fms, sbs) theme.

Also some bitmaps showing with artefacts. Note central icon in system statusbar. It's very differs from real shuffle.bmp in resources.

Sorry for my English.
Comment by Ravestein (sraaf) - Friday, 16 December 2011, 12:22 GMT
"any theme" Which one is that?

Perhaps next info might help:
My Clip+ only freezes when trying to activate none Clip+ compatible themes
Installed (using RBUtil) and activated "ClipLined" ( themes.rockbox org "sansaclipplus" )
Removed not compatible themes (on runtime): Settings, Theme Settings, Browse Theme Files, long press and "delete"


Comment by James Hunt (james_hunt) - Sunday, 18 December 2011, 02:04 GMT
Ravestein, info was not full and outdated. New discovery below.

I've really thinked before, that something changed in bitmaps rendernig beacuse corrupted icons was edited by me in PS or Paint.
But after long experiments with editing BMP's by various soft and using original I found the problem lies elsewhere.

In attached test theme icons of shuffle and disc access dispalying with artefacts. But no errors while changing any theme.
We will deal with disc icon. Viewport is %V(108,0,6,7,-) and dimensions of BMP 9x9. This good icon in archive have name disk_ok.bmp.
If replace it to more correct BMP with dimensions 6x7 player crashes when selecting any theme. Someone can to explain this strange behaviour?
I would remind that bug was appeared in 31107 and higer builds.

How to reproduce bug:
1. Set all themes to default (failsafe)
2. Select attached theme. All fine.
3. Reboot player. Icons of shuffle and disk now will be corrupted.
4. Select ANY, even failsafe theme or connect USB (in new builds it finally enabled. Thanks to devs!).
5. Behaviour in new builds changed, now player NOT freezes, but show "Data abort at 30004DF84. FSR 0x8 (domain 0, fault 8) address 0xB6854914)". Last address changing any time, of course.

Sorry again for my English.
   Test.zip (1.9 KiB)
Comment by James Hunt (james_hunt) - Thursday, 22 December 2011, 11:39 GMT
Bug disappeared in 31400 (maybe bit earlier), thanks for fixing!

Loading...