Rockbox

Tasklist

FS#5269 - can't turn on iriver with the h300 non-lcd remote

Attached to Project: Rockbox
Opened by Daniel Andersson (Daniel_A) - Monday, 01 May 2006, 19:44 GMT
Last edited by Frank Gevaerts (fg) - Wednesday, 16 December 2009, 19:30 GMT
Task Type Bugs
Category Bootloader
Status Unconfirmed
Assigned To No-one
Operating System Iriver H300 series
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When using the H300 non-lcd remote to turn on the player (iriver H340) I get the following error message "hold switch on, power off..." (the hold switch is not on).
This task depends upon

Comment by Simon Malinge (Tapi) - Thursday, 17 August 2006, 15:21 GMT
I have the same issue with my H340.
I'm using 1.30EU firmware, and the 20060816 daily build.
Quite annoying... :/
Comment by Steve Bavin (pondlife) - Tuesday, 24 October 2006, 09:34 GMT
This is a bootloader issue - confirmed present here with bootloader version 5.
Comment by Steve Bavin (pondlife) - Monday, 05 March 2007, 11:51 GMT
The problem occurs because the code which detects the hold switch is executed before the code which detects the remote type.
Comment by Steve Bavin (pondlife) - Wednesday, 07 March 2007, 11:54 GMT
It's now fixed in SVN if you're happy building your own bootloader! Hopefully there will be a new release soon.
Comment by Kévin Ferrare (TiMiD) - Saturday, 23 June 2007, 05:55 GMT
The problem occurs on my h140 with the standard LCD remote (I can't turn my player on when the remote is connected)
I use a bootloader compiled from today's SVN.
Comment by Steve Bavin (pondlife) - Saturday, 09 February 2008, 15:55 GMT
Kevin, looks like the H100 bootloader may have just had this fixed.
Comment by Kévin Ferrare (TiMiD) - Saturday, 09 February 2008, 16:03 GMT
I'll take a look when the others will have tested first as I don't wanna brick my unit :D
Comment by Kévin Ferrare (TiMiD) - Wednesday, 13 February 2008, 11:52 GMT
OK updated to 7pre4 bootloader, workds like a charm with the remote !

Does the bug still occurs on H3x0 players ?
Comment by corncobman (corncobman) - Friday, 06 June 2008, 19:00 GMT
I just tried it with a non-lcd remote (bootloader 5) and this occurs.

Any chance of there being an updated bootloader somewhere that fixes this problem?
Comment by Steve Bavin (pondlife) - Monday, 09 June 2008, 08:08 GMT
One of the plans for DevCon, or shortly after, is to get a new set of bootloaders out. The H300 could really do with an update.
Comment by Johannes Linke (Jaykay) - Wednesday, 29 July 2009, 13:45 GMT
is this fixed now?
Comment by Steve Bavin (pondlife) - Wednesday, 29 July 2009, 14:14 GMT
It's been fixed for some years - the outstanding issue is that some (other) change in the past few years has made the current SVN bootloader fail to boot on some H300s.

This means no new bootloader can be released until that issue has been resolved by a developer who can reproduce the problem.

Sadly, my H300 works fine with the later bootloaders, although I've not tried SVN recently.
Comment by Ed (ED-209) - Thursday, 19 November 2009, 05:36 GMT
I have the same problem with my h300 ired remote.
I am using the current build as of this date
Comment by Steve Bavin (pondlife) - Thursday, 19 November 2009, 10:00 GMT
Yes, but the problem is in the bootloader, and I expect you're using the latest released one (v5) that dates from some years back.

If you're prepared to permanently brick your H300 you could try building a new bootloader from SVN, but I wouldn't recommend it.

We *really* need a new H300 bootloader release - I must pester LinusN some more as if he hasn't done enough for his sins ;-)
Comment by Bryan Childs (GodEater) - Wednesday, 30 December 2009, 07:07 GMT
Please note that Steve actually got around to trying out a new bootloader built from SVN in December, and it bricked his H300 - so no-one should attempt to build and apply their own until further notice.
Comment by Christoph Goesgens (Suckerville) - Tuesday, 06 December 2011, 13:29 GMT
So, is there any news on this? It's been two years since the last comment. I just bought an LCD Remote for my H300, and i'd like to use it ;)
Comment by Alexander Spyridakis (xaviergr) - Friday, 09 December 2011, 18:17 GMT
An LCD remote should turn on the main unit as intended. It is the non-LCD remotes that have this problem.

Loading...