Rockbox

Tasklist

FS#5318 - playback stops unexpectedly

Attached to Project: Rockbox
Opened by Robert Kukla (roolku) - Monday, 08 May 2006, 08:58 GMT
Last edited by Dave Chapman (linuxstb) - Thursday, 25 May 2006, 20:08 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity High
Priority Normal
Reported Version
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This is difficult to reproduce, as it usually only happens after playing several albums worth of music (playlist or auto change dir). The playback stops in the middle of a song and I can't get it to restart whatever I try (toggle pause, stop/play, select different song). Only solution I have found is to shut down and restart in which case it auto-resumes without problems. One thing I noticed is that the wps gets somewhat corrupted when skipping in aforementioned (silent) state - notably the year field suddenly contained the replaygain value. It has happened often enough on different files to rule out corrupted files. Also they play without problems after restart. All my files are mp3. I'll try to collect more information, but it is difficult as it usually happens when I am out and about. Has anyone else experienced this?
This task depends upon

Closed by  Hardeep Sidhu (hardeeps)
Tuesday, 06 June 2006, 19:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  I believe this is fixed. Please re-open bug if you see it again.
Comment by Hardeep Sidhu (hardeeps) - Saturday, 03 June 2006, 17:28 GMT
Please try to reproduce on latest CVS build.
Comment by Robert Kukla (roolku) - Tuesday, 06 June 2006, 15:55 GMT
I have been using it for a few days now and haven't experienced the bug. So fingers crossed it's gone.

Cheers
Roolku

Loading...