Rockbox

Tasklist

FS#5364 - "NAVI = Yes" for iRiver H100/H120/H300 (most languages)

Attached to Project: Rockbox
Opened by Alexander Bondar (davinci) - Monday, 15 May 2006, 11:52 GMT
Last edited by Matthias Mohr (aka Massa) (mmohr) - Sunday, 30 July 2006, 18:35 GMT
Task Type Patches
Category Language
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

No more wrong "PLAY = Yes" in the dialogs. Now "NAVI = Yes" in Eglish and "NAVI = Ja" in German language files.
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Sunday, 30 July 2006, 19:18 GMT
Reason for closing:  Accepted
Additional comments about closing:  Thanks. How about fixing the remaining LANG_BOOKMARK_SELECT_PLAY entries too?
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 15 May 2006, 12:27 GMT
I think it would be better to call it SELECT instead of NAVI. In Rockbox, the joystick button has always been SELECT, and it works for the X5 as well.
Comment by Alexander Bondar (davinci) - Monday, 15 May 2006, 12:29 GMT
But "NAVI" is writen on the button.
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 15 May 2006, 12:30 GMT
Not on the H100, and we'd like to treat both platforms the same.

Comment by Alexander Bondar (davinci) - Monday, 15 May 2006, 12:36 GMT
So why do we have "h100" and "h300" for the language files?
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 15 May 2006, 12:51 GMT
My point is that we want to have a common name for the joystick button on all the joystick targets. Maybe that's not a good idea, what do you think?
Comment by Alexander Bondar (davinci) - Monday, 15 May 2006, 13:47 GMT
H300 has on itself no joystick. Joystick can be used for more actions than the NAVI button (only press or hold).

And I don't think that all H300/H100 user own a remote.
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 15 May 2006, 13:58 GMT
Of course. Then it should be NAVI on the H300 at least, like your patch suggests.
Comment by Alexander Bondar (davinci) - Monday, 15 May 2006, 15:27 GMT
Will you add this patch to CVS?
Comment by Peter D'Hoye (petur) - Tuesday, 23 May 2006, 12:46 GMT
and call the h1x0 joystick 'joystick'
Comment by Mike Schmitt (Falco98) - Tuesday, 06 June 2006, 03:00 GMT
"navi" is written on the h100 on the remote...?
Comment by Benoit-Pierre Guay (benacool) - Thursday, 29 June 2006, 14:16 GMT
Mike (Falco98) said : "navi" is written on the h100 on the remote...?

Yes, on the H100 remote, the button to go in the browser and in the settings menu is named "NAVI/MENU".
Comment by Benoit-Pierre Guay (benacool) - Thursday, 29 June 2006, 14:20 GMT
Little error... Forget the "and in the settings menu" I said in my last comment.
Comment by Matthias Mohr (aka Massa) (mmohr) - Sunday, 30 July 2006, 14:04 GMT
Here is an updated patch which calls it
"NAVI = yes" for h300 and
"SELECT = yes" for h100/h120
for all languages except japanese and hebrew
(I'm unable to edit those at my system...)
and afrikaans, bulgarian, romaneste and turkce
(they don't contain that LANG-ID - are they up to date?)

BTW, there have been a few lanuages (e.g. catala) where
the "NAVI = yes" for h300 is already included in CVS!
Comment by Linus Nielsen Feltzing (linusnielsen) - Sunday, 30 July 2006, 15:13 GMT
After some discussion on IRC, we have come to the conclusion that it should be called "NAVI" on both H100 and H300, since the original iriver manual calls it NAVI.
Care to fix? Then I will commit.
Comment by Matthias Mohr (aka Massa) (mmohr) - Sunday, 30 July 2006, 18:34 GMT
O.K. here is a version with "NAVI" for both the H100, H120 and H3x0...

BTW, is "PLAY" O.K. for all other targets?
Or would it be better for them to also have a different name for them?

Loading...