Rockbox

Tasklist

FS#5529 - Tagcache Problem with too many songs

Attached to Project: Rockbox
Opened by Music_Monster (mfunky) - Sunday, 11 June 2006, 12:14 GMT
Last edited by Steve Bavin (pondlife) - Wednesday, 27 September 2006, 07:27 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iPod 4G Color
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have an Ipod 4G Color and tried to activate the tagcache for a collection of 12.000+ Songs (~60 GB, mainly AAC-encoded). As it worked for smaller collections (also AAC), it did not work out for my full collection. The tagcache_tmp file in .rockbox is not deleted, committing tagcache at startup broke at 4/10. When trying to use ID3-Database, I get the error "tagcache not ready".
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Saturday, 30 September 2006, 17:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed according to cvs logs. If it still happens, please open a new task.
Comment by Yoshihisa Uchida (Uchida) - Saturday, 05 August 2006, 19:33 GMT
I happens to same probleam for iPod 5G video 60GB (into about 9000 ogg-vorbis formatted songs).
Rockbox version is 2006/8/3.


Comment by Kavon Daftari (kavond) - Thursday, 17 August 2006, 20:52 GMT
I have a 4G color as well with 10,379 files (60GB mostly MP3's). Rockbox version 2006/8/17. It takes about 30 min for the tagcache to run. I rebooted and the cache was applied however when attempting to access music it said tagcache not ready. I disabled load to RAM and re-ran initialize now and it ran for another 30 minutes. But this time it worked. Hope this helps.
Comment by gavfung (Drkepilogue) - Monday, 28 August 2006, 02:46 GMT
Same problem here. I wonder, does haveing songs in the apple Frimware have any effect on how tagcache work. Also, when i hit initalize now, the HD spins for less than 2 minutes.
Comment by Yoshihisa Uchida (Uchida) - Sunday, 03 September 2006, 19:49 GMT
I sent the patch file of this bug (FS #5934).

Please confirm the following execution file (FS #5534 applied file) is used,
and this bug doesn't occur.

Moreover, please give the report to me when this files are used, and the problem
occurs.

It is thought this bug having occurred because there are a lot of songs with
too long title (> 20 bytes).
Comment by Steve Bavin (pondlife) - Wednesday, 27 September 2006, 07:27 GMT
A fix for this was committed yesterday, please get a new build and retest.

Loading...