Rockbox

Tasklist

FS#5710 - Data Abort 0004A704

Attached to Project: Rockbox
Opened by Wes (wax4213) - Monday, 24 July 2006, 16:16 GMT
Last edited by Rani Hod (RaeNye) - Tuesday, 19 September 2006, 10:25 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod 4G Grayscale
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

iPod 4G 20gig grayscale freezes during mp3 playback and displays the Data Abort at 0004A704 error, requiring a restart to begin listening to music again. WPS is zezayer, crossfeed is on with the default settings, and tag cache is enabled but not auto updating. This occurs on all the latest CVS builds, current build on the iPod is 060723-0143. I don't know if this is specific to playing back mp3's, as it does not happen more than once every 6 hours of listening or so, and my iPod only has mp3's on it.
This task depends upon

Closed by  Steve Bavin (pondlife)
Tuesday, 10 April 2007, 06:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  Appears to be fixed with the updated bootloader and COP support.
Comment by Rani Hod (RaeNye) - Monday, 18 September 2006, 17:18 GMT
Does the problem persist with current CVS?
Comment by Wes (wax4213) - Tuesday, 19 September 2006, 07:53 GMT
Yes, this problem still occurs. I just had it happen after updating to the latest CVS and fonts, and on the 14th song it froze partway through. It was an mp3 encoded with LAME at V2, for reference.
Comment by deTerrence Brooks (deterrence) - Wednesday, 04 October 2006, 12:39 GMT
I have this exact same problem. It freezes on average every 10th song, and something like every other song when the player is in my pocket walking. Does anyone know if earlier revisions do not have this problem?
Comment by sublimal (sublimal) - Wednesday, 11 October 2006, 09:10 GMT
I can also confirm this issue on a 40Gb 4G grayscale running 20061010 daily, same WPS, no crossfade. Data abort at 0004E050. All played audio was MP3 encoded.

The issue is occuring quite frequently (4 times out of 10 songs). Occurrance of the error is always on differnet songs and at different timestamps. This frequency of the issue may be related to  FS#5820 , as battery was low at the time.
Comment by as (as_tit) - Wednesday, 11 October 2006, 23:11 GMT
I've got the same: data abort at 0004e0505 while playing mp3 var bit 186, or 196 non variable - the battery is full, and the ipod (4g b/w) on the table, any opinion about on?
Comment by Wes (wax4213) - Thursday, 12 October 2006, 07:37 GMT
I now get different data aborts, but it always happens under similar circumstances. LAME MP3 V2's, full battery, sometimes charging (but not usually), no EQ, same WPS, no crossfeed. Sometimes it just freezes and doesn't give a data abort. Unfortunately, this is a big enough deal for me that I when I listen, I update Rockbox, listen until it freezes, then go back to the Apple OS.
Comment by Steve Bavin (pondlife) - Friday, 13 October 2006, 07:00 GMT
I wonder if this is caused by CPU boost. Please could somebody who's seeing this please start with a fully charged battery, then manually boost the CPU (under Info > Debug > CPU frequency) before playing. Then see if it still happens. Of course, boosting CPU may use up the battery much quicker.

I don't have a 4G, so apologies if there is no CPU boost option available.
Comment by Austin Vaughan (dapreview) - Friday, 13 October 2006, 12:57 GMT
I have a 4G iPod, 40gb, greyscale. Love Rockbox, but it is very unstable on this particular model. Firmware from CVS about a week ago. Crashes at least twice an hour with either a Data Abort message or simple lock-up. I am able to reboot and start again. Haven't been able to determine any particular cause, as it happens while playing MP3, OGG, and FLAC tracks. No options are turned on, everything is default. Thanks for your efforts so far and let me know if I can be of any assistance.
Comment by Steve Bavin (pondlife) - Thursday, 19 October 2006, 12:12 GMT
Austin, you can be of assistance! Did you increase the CPU boost like I asked before? Or is that option not available?
Comment by Geoff Stokes (iwantanimac) - Friday, 20 October 2006, 14:27 GMT
I too get data aborts on my iriver H10 5GB. The boostign is disabled on the H10 and is set to 100% anyways. It usually occurs when plaiyng music and either viewing pictures or using plugins. Resetting the player fixes it for a short while. It isn't that often that it does occur, but it still occurs.
Comment by deTerrence Brooks (deterrence) - Saturday, 21 October 2006, 16:44 GMT
Ok, it seems that Steve Bavin is on to something. I set CPU boost to 1 (750000) and this seemed to resolve the issue. The penalty to battery life is hard to judge since the 4G couldn't play for more than 30 minutes at a time before, but after this resolution it will play continuously for 6 hours on my brand new iPod 4G grayscale (remember to set battery capacity to 630 mAh) the before draining. I hope this helps diagnose the problem for future updates and can at least help out on the short run for those of us who aren't developers. :-)
Comment by Erik Jacobsen (thejake) - Tuesday, 24 October 2006, 19:16 GMT
I can also confirm that setting CPU boost to 75000000 1m seems to completely resolve this problem. I'm using the 4G grayscale, 20 GB model, 10/23 daily build. Tested with full battery at start. With no cpu change, I would get a data abort every ten minutes or
so (in a Poisson sense, in different files at different times). With the change, I haven't seen a freeze in over ten hours of the same playlist.

Comment by David Joham (djoham) - Wednesday, 29 November 2006, 04:38 GMT
I'm also seeing the data abort issue on my 20G 4G. I'm trying the fix - so far so good. One question though: how do you get this fix to persist between power cycles? After I shut down and restart, the CPU clock is back to the original setting and I have to change it again?

Thanks

David
Comment by Erik Jacobsen (thejake) - Thursday, 30 November 2006, 17:03 GMT
Try the "noscaling" builds on: http://mikeage.net/content/rockbox/

Comment by Dan (SpaceFuzz) - Saturday, 02 December 2006, 04:53 GMT
Thank you! Thank you! RockBox is fun again. I was having the same problems on my Mini 1G 4GB iPod (playback of songs would freeze at random points or generate a Data Abort Error 00041B04, using the latest CLEAN 20061130 release). Turning the CPU Boost to 1 as instructed above eliminated the problem. Forgetting to turn the CPU Boost back to 1 after a power-on, will definitely cause it to crash again with 10 minutes or so).

My iPod does not fall under the original Bug Report, so I don't know if I should report this separately for the iPod mini 1G, or if this comment is enough to let other users know the bug may be relevant to a wider selection of devices.
Comment by Dan (SpaceFuzz) - Saturday, 02 December 2006, 05:01 GMT
Correction, it was Data Abort 00041D04, (not ...B04).
Comment by Steven (SorcererSteven) - Tuesday, 06 March 2007, 21:44 GMT
I have a 4GB 1G Nano, and on each build since 2007-03-05 I get the Data Abort error every single time I try to play any type of music. I have tried MP3s, OGGs, SPCs and FRMs. The error 0002FA68 appears every time (with the 2007-03-06 build, it was different on the 05 build).
The error still occurs with CPU Boost at 1.
A fix soon would be nice ^_^. But the older builds still work... Guess I'll just have to wait.
Comment by Steve Bavin (pondlife) - Wednesday, 07 March 2007, 07:11 GMT
Steven, can you make sure you've updated your bootloader to one that supports the co-processor. That should fix it.
Comment by Steven (SorcererSteven) - Wednesday, 07 March 2007, 22:13 GMT
Eeeps. I didn't think it would be so easy to update the bootloader.
That's new, from when I fist installed RockBox ^_^.
So, I've done that now, and I've installed the newest release...
And it seems to work fine. Thanks a lot!
Comment by Steve Bavin (pondlife) - Wednesday, 21 March 2007, 12:22 GMT
Please can anyone who's had this problem try the latest bootloader and build, then report back if they still have Data Abort issues?

If it's all quiet, I'll close this bug.
Comment by Gunnar (gungam) - Friday, 06 April 2007, 00:02 GMT
Hi!

i just installed the latest build (070405) on my ipod photo 60gb and had the same problem. after i installed the latest bootloader rockbox worked fine!
so to all with this problem:
install the new bootloader ;)

Loading...