Rockbox

Tasklist

FS#5713 - player freezes when generating 6th consecutive Sudoku game

Attached to Project: Rockbox
Opened by Joaquim Dias (dunno) - Tuesday, 25 July 2006, 10:43 GMT
Last edited by Daniel Stenberg (bagder) - Monday, 30 July 2007, 07:58 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Player will freeze whilst music is playing, and after generating 5 or 6 Sudoku games consecutively. (Repeat 'hard' generating cycle twice).
To get to the 'Hard' games I generate 'medium' games until I got to a 'hard' game, it does it fine the first time/cycle, then after completion of one hard game I would repeat the generating cycle to attain a 'hard', and this is when I would get the player freeze, the buttons are unresponsive although the music continues playing in the background, a pin reset is the only way I can restore my player.

mp3-LAME@aps.
Rockbox std build of 23rd.
This task depends upon

Closed by  Daniel Stenberg (bagder)
Monday, 30 July 2007, 07:58 GMT
Reason for closing:  Out of Date
Additional comments about closing:  No response
Comment by Will Robertson (aliask) - Tuesday, 25 July 2006, 11:05 GMT
I don't know that this happens on the 5th or 6th generate - I've had similar effects after a single one.
This happened to me quite a while ago - maybe a month, but it seemed that the problem actually fixed itself after a while (no estimated time - I just stuck the player in my pocket and continued to listen to the music that was playing).

Perhaps the generate funtion just needs a timeout.
Comment by Will Robertson (aliask) - Sunday, 06 August 2006, 12:51 GMT
Just thinking about this... if it's still playing music, would that mean it's in an infinite loop with a yield in it? Took a quick look at the code but I couldn't see anything, just thought I'd share the idea.
Comment by Joaquim Dias (dunno) - Sunday, 06 August 2006, 15:51 GMT
yes the bug occurs whilst music is playing
Comment by Steve Bavin (pondlife) - Monday, 02 October 2006, 08:41 GMT
My gut feeling is that this is a menu recursion issue, like  FS#6010 . If anyone can reproduce it, please try it out in the sim under gdb.
Comment by Jonathan Gordon (jdgordon) - Monday, 12 March 2007, 12:54 GMT
I couldnt reproduce this in the sim or on my h300 (if it crashes the h100 it should crash the h300 also)

is it still a problem?

Loading...