Rockbox

Tasklist

FS#5715 - iPod Nano - hold Menu button on USB insert doesn't work

Attached to Project: Rockbox
Opened by Matthew Caron (mattcaron) - Tuesday, 25 July 2006, 15:03 GMT
Last edited by Will Robertson (aliask) - Monday, 30 July 2007, 05:18 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System iPod Nano
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Version: CVS-060724

(1) Hold menu button
(2) Insert USB cable
(3) Screen displays USB splash
(4) Reboots to apple "Do not Disconnect" screen
(5) (still holding menu)
(6) Reboots "Apple" boot splash screen
(7) (still holding menu)
(8) Screen goes blank.
(9) Release menu
(10) Boots Rockbox
(11) As soon as Rockbox boots, it displays USB splash and reboots to apple "Do Not Disconnect" screen
This task depends upon

Closed by  Will Robertson (aliask)
Monday, 30 July 2007, 05:18 GMT
Reason for closing:  Fixed
Comment by Dave Chapman (linuxstb) - Tuesday, 25 July 2006, 15:18 GMT
Did you do step 0 - Turn on the ipod and wait for Rockbox to boot?

The "hold menu to charge" feature only works when Rockbox is actually up and running.

Comment by Matthew Caron (mattcaron) - Tuesday, 25 July 2006, 15:24 GMT
Yes. Rockbox was up, running, and playing music.
Comment by Paul Louden (darkkone) - Tuesday, 01 August 2006, 00:11 GMT
One thing, if the USB cable is plugged in before Rockbox boots, you'll drop into USB mode every time (or at least every time in my experience).

If you fail to get it right, remove the cable before the iPod reboots when rebooting to Rockbox to try again.
Comment by Matthew Caron (mattcaron) - Wednesday, 02 August 2006, 02:29 GMT
I've tried it every which way I can think of, and I can't get it to work.
Comment by Will Robertson (aliask) - Monday, 30 July 2007, 01:29 GMT
Does this still happen? It seems that this is a pretty isolated case.
Comment by Matthew Caron (mattcaron) - Monday, 30 July 2007, 03:37 GMT
I just checked it and it now seems to be working just fine.

Requesting closure of ticket.

Loading...