Rockbox

Tasklist

FS#6130 - Control problem on H10 (5gb)

Attached to Project: Rockbox
Opened by Mathieu Stempell (dma) - Friday, 06 October 2006, 12:50 GMT
Last edited by Nils Wallménius (nls) - Friday, 07 March 2008, 23:20 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System iriver H10
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After remote support introduction, the controls are totaly messed on the H10 here (5gb model).

The problematic source files are :
- apps/keymaps/keymap-h10.c >1.9
- firmware/target/arm/iriver/h10/button-h10.c >1.9
- firmware/target/arm/iriver/h10/button-target.h >1.1
This task depends upon

Closed by  Nils Wallménius (nls)
Friday, 07 March 2008, 23:20 GMT
Reason for closing:  Out of Date
Additional comments about closing:  No response for several months
Comment by Geoff Stokes (iwantanimac) - Friday, 20 October 2006, 14:29 GMT
Waht do you mean? The controls work fine?

The Play button on the player itself not working was a bug that was ironed out almost immediately, so i don't know waht it could be.
Comment by Mathieu Stempell (dma) - Monday, 23 October 2006, 20:23 GMT
Some RockBox official knows about the problem.
But so what happens, is that the controls don't respond or sometimes they do after a while, sometimes not doing the action they're supposed to, really messed up. :)
And when i build RockBox with the previous version of the listed sources files (before remote support introduction), it works fine.
Comment by Geoff Stokes (iwantanimac) - Tuesday, 24 October 2006, 09:09 GMT
That usually happens on "pure" models - those without the FM radio. If you're running one of those, then it's definitely known. It was also knwon to happen to a select few "Early Model" H10s. If your model is very old, then that may also be part of the problem.
Comment by Mathieu Stempell (dma) - Thursday, 26 October 2006, 22:02 GMT
Ah this one got the radio, but it's probably an early one anyhow as you stated.
Comment by Mathieu Stempell (dma) - Sunday, 18 March 2007, 20:41 GMT
OK, after several months i wanted to build RockBox for this H10 again and the solution to correct the control problem is still the same : Removing remote references in the 3 files that i listed in the detail of this bug report.
Comment by Barry Wardell (barrywardell) - Thursday, 25 October 2007, 09:33 GMT
I've recently made a change to the way the ADC is read. This might improve remote button readings. Can you please try the latest svn build and report back on whether it fixes the problem?

Loading...