Warning: mysqli_real_connect(): Headers and client library minor version mismatch. Headers:50625 Library:50543 in /sites/rockbox.org/flyspray/adodb/drivers/adodb-mysqli.inc.php on line 108 FS#6306 : Rename Tagcache to Database



FS#6306 - Rename Tagcache to Database

Attached to Project: Rockbox
Opened by Jonas Häggqvist (rasher) - Wednesday, 08 November 2006, 14:24 GMT
Last edited by Dominik Riebeling (bluebrother) - Wednesday, 08 November 2006, 16:26 GMT
Task Type Patches
Category Playlists
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


As discussed on IRC, this patch renames tag cache to simply Database. Includes changes to manual and english.lang as well as changing the names of the files tagcache writes to disk. Pretty much untested, so give it a whirl.
This task depends upon

Closed by  Jonas Häggqvist (rasher)
Saturday, 25 November 2006, 09:53 GMT
Reason for closing:  Accepted
Additional comments about closing:  Committed to cvs
Comment by Dominik Riebeling (bluebrother) - Wednesday, 08 November 2006, 16:30 GMT
I think the attached patch qualifies this as a patch, not a bug ;-) Feel free to change it back if you disagree.

I think it would be better to rename it to "Tag Database" instead of simply "Database" -- this doesn't give a hint what is used to build the database, users might expect it to contain everything, including e.g. images, wave files etc. Additionally, I don't think renaming the tagcache files itself is necessary -- we can always argue that this is still the internal name when pointing a user to remove the tagcache files (and, in most cases this will only be "remove all *.tcd files, so the basename itself doesn't matter that much)
Comment by Jonas Häggqvist (rasher) - Wednesday, 08 November 2006, 16:38 GMT
Thanks for fixing the wrong fields, I simply forgot to change them when submitting.

If we were to call it more than just database, I'd think "Music Database" was better. The reason why I moved the files were because they were mentioned in the manual (tagcache_changelog), but I agree it isn't strictly necessary. But on the other hand, there are no real ill effects other than people having to rebuild.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 08 November 2006, 19:01 GMT
I think "database" is the best, nice and simple.
Comment by Nils Wallménius (nls) - Wednesday, 08 November 2006, 20:00 GMT
I vote for simply 'database' too.

rasher, I think you missed one here:
- \\item[ID3 Database:] This shows the files based on the \\setting{Tag Cache}

+ \\item[ID3 Database:] This shows the files based on the \\setting{Database}

Should probably be: (as the string changed in the .lang file)
(maybe it could be called something like "Database view"?)
- \\item[ID3 Database:] This shows the files based on the \\setting{Tag Cache}

+ \\item[Database:] This shows the files based on the \\setting{Database}

Also the change to rockboxdev.sh (the last part of the patch) was not supposed to
be there, right?
Comment by Jonas Häggqvist (rasher) - Thursday, 09 November 2006, 13:23 GMT
nls: Right, right and right. Fixed.

I also fixed some occurrences of "The Database database" (caused by recklessly replacing "Tag Cache" with "Database") and stopped treating database like a proper noun in most places (except when referring to the setting).

The only user-visible left is the configfile options, which are still called tagcache_*, but I'll leave those.