Rockbox

Tasklist

FS#7104 - Skipping tracks with crossfade causes click on x5

Attached to Project: Rockbox
Opened by philip kao (philibuster) - Thursday, 03 May 2007, 22:52 GMT
Last edited by Marc Guay (Marc_Guay) - Sunday, 01 June 2008, 14:33 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iAudio X5
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When the track is changed mid-song, there is an audible click. This is pretty minor, but it's a little annoying.
This task depends upon

Closed by  Marc Guay (Marc_Guay)
Sunday, 01 June 2008, 14:33 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Silence = Out of Date.
Comment by Michael Sevakis (MikeS) - Friday, 04 May 2007, 17:41 GMT
Things used to get muted on every playback start and stop but this would actually cause problems with voice and FM. These were far more annoying since radio would go silent every time a new menu item was selected come back. The muting really didn't help much in general anyway and just changed the character of the click. Maybe your's is clickier than most since mine really doesn't. Do you really mean just an abrupt start/stop or "pop" like when starting?
Comment by philip kao (philibuster) - Friday, 04 May 2007, 17:47 GMT
It's like a pop.

I actually tested it again, and with crossfade enabled and zero-second delays and durations (fade-out and fade-in), it has a faint click. Without crossfade enabled, it doesn't exist. Strange.
Comment by Marc Guay (Marc_Guay) - Wednesday, 02 April 2008, 17:52 GMT
Can someone confirm or deny if this is still happening?

Loading...