Rockbox

Tasklist

FS#7397 - Crash on rec shut down

Attached to Project: Rockbox
Opened by Fed (Fed) - Wednesday, 04 July 2007, 07:24 GMT
Last edited by Michael Sevakis (MikeS) - Wednesday, 25 July 2007, 05:37 GMT
Task Type Bugs
Category Recording
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Crash when shut down from recording screen on latest build.
This task depends upon

Closed by  Michael Sevakis (MikeS)
Wednesday, 25 July 2007, 05:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  Problem solved. And again deleted IE errant post ... what gives? :\
Comment by Jonathan Gordon (jdgordon) - Monday, 23 July 2007, 10:20 GMT
its not a crash at all. its just a loop somehwere shich takes about a minute to finish.
Comment by Michael Sevakis (MikeS) - Monday, 23 July 2007, 19:03 GMT
Shutdown can't proceed until the data is saved of course. Is this even a bug?
Comment by Jonathan Gordon (jdgordon) - Monday, 23 July 2007, 21:49 GMT
not sure, I tried it without doing a recording... just entering the rec screen
Comment by Michael Sevakis (MikeS) - Tuesday, 24 July 2007, 04:01 GMT
If you have a buffer full of data, expect a decent wait for it to save. The only thing that ever broke shutting down from the recording screen was a power management patch that ended up calling yield from an ISR. Unless something new was added to shutdown that does a bad thing, there should be no issue here.

(Note: previous comment that I added then deleted was duplicate that an errant keystroke created :-)
Comment by Jonathan Gordon (jdgordon) - Tuesday, 24 July 2007, 06:51 GMT
it shouldnt be trying to save anything... the only thing in the buffer is the prerecording, but seen as rec was never actually started the data should be dumped.
Comment by Michael Sevakis (MikeS) - Wednesday, 25 July 2007, 00:08 GMT
I don't think fed specified about the shutdown conditions so I really don't know. If recording is not active (read: audio_status() & AUDIO_STATUS_RECORD == 0) no disk access should occur. Are you saying you can reproduce the problem when _not_ recording and trying to shut down? I've never seen a problem myself.
Comment by Jonathan Gordon (jdgordon) - Wednesday, 25 July 2007, 00:32 GMT
yes... but just tested again and it seems prerecording could be the problem. (i just tested shutting down in the rec screen while recording and while doing nothing, but both with prerec off)..
hmm, i have no problem closing this task
Comment by Fed (Fed) - Wednesday, 25 July 2007, 04:53 GMT
Sorry, I forgot to mention that I was prerecording.
I tried the new build (SVN 13975), and it works fine. Issue resolved as far as I can see.
Thanks!!

Loading...