Rockbox

Tasklist

FS#7636 - Blank fields in Polish Translation (polski.lng)

Attached to Project: Rockbox
Opened by Pawel Wysocki (sic-ever) - Tuesday, 21 August 2007, 11:32 GMT
Last edited by Jonas Häggqvist (rasher) - Tuesday, 15 January 2008, 10:05 GMT
Task Type Bugs
Category Language
Status Closed
Assigned To Jonas Häggqvist (rasher)
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi!
I noticed one huge bug in firmware. File polski.diff is full translated. I used http://rasher.dk/rockbox/translate/?cmd=edit&lang=polski for translation and each one field was written. But when i have downloaded Rockbox 21.08.07 and change on polish language, I saw blank fields by icon e.g . Recording (Nagrywanie), Radio FM. It seems like polski.lng is not synchronizated properly with FW or you have a problem with compilation. In attachement, you have screendumps. Odd things is that, in polski.lng e.g. "Nagrywanie" isn't there, but in polski.diff it is. Maybe if you give me original english language file, I will translate it step by step. In my opinion it'll be safer.
Could you help me in this problem?

Greets, Pawel Wysocki.
This task depends upon

Closed by  Jonas Häggqvist (rasher)
Tuesday, 15 January 2008, 10:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed since r14414.
Comment by Pawel Wysocki (sic-ever) - Tuesday, 21 August 2007, 11:38 GMT
I forget about, that I'm using Sansa e260.
Comment by Jonas Häggqvist (rasher) - Tuesday, 21 August 2007, 12:51 GMT
Yes, I see this problem. It's actually due to how the translation page is set up. You have probably not paid close attention to some of the fields - and it can be a bit confusing, I admit.

I think I'll be able to fix it automatically, so there's no need to start over for now.
Comment by Pawel Wysocki (sic-ever) - Tuesday, 21 August 2007, 13:54 GMT
Ok, I was worried about it, because some of my friends and not only them, were asking about "normal translation". You know "English is veeery difficult to learn".
Comment by Jonas Häggqvist (rasher) - Thursday, 23 August 2007, 22:19 GMT
"I've noticed that polish language is working properly only in r14414-070821. Next builds still includes bug with empty fields. I've checked this up. I can't help in this. You must work this out why is this happening."

I don't understand what you mean by this. The last change to polski.lang was in r14414. Since then, the Polish language has remained the same. Are you saying that r14414 works fine, but later versions do not? If so, this is not a problem with the language file, but I highly doubt this to be the case. I urge you to retest with a current build, as I suspect you may not have.

Please also state which specific language IDs are showing up blank.

I do know why this happened: Because you hadn't followed the instructions and left strings untouched that should have been changed. If my automatic fix didn't do it, I'm afraid I can't do more, and you'll have to go through the language file yourself and fix the phrases that aren't correctly translated.
Comment by Jonas Häggqvist (rasher) - Tuesday, 15 January 2008, 09:34 GMT
Is this still an issue with the current build?

Loading...