Rockbox

Tasklist

FS#7730 - frequent crashes during playlist or file loading

Attached to Project: Rockbox
Opened by Przemysław Hołubowski (p.h.) - Saturday, 08 September 2007, 08:26 GMT
Last edited by Nicolas Pennequin (nicolas_p) - Monday, 07 January 2008, 21:50 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iriver H10
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi!

The bug concerns H10 20GB.

1. Rockbox crashes when loading M3U playlist files - you can load 0 to 3 maybe 4 playlists in a row and during loading next playlist Rockbox hangs with "Loading..." message.
(The same concerns audio files)
Workaround: you can que playlists or files.

2. Rockbox sometimes crashes on splash screen during starting.

3. Rockbox sometimes stops playing file (stops in a random point) and you have to play the file again.

I have found out that the last revision which is free from the bug is rev. 14571. Starting with rev. 14590 mentioned above problems occur.

It is interesting to note that H10 5GB using rev. 14599 works fine.
--
regards,
przemysław hołubowski
This task depends upon

Closed by  Nicolas Pennequin (nicolas_p)
Monday, 07 January 2008, 21:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  Closing at request of the reporter
Comment by Corey (blackthunder) - Saturday, 08 September 2007, 23:05 GMT
I am having the same problems with my h10 20gb using recent builds.
Comment by Nikkhil (AceNik) - Monday, 17 September 2007, 20:00 GMT
i agree with these bugs on the h10[20GB] however the one bug where you try to open a .wps file with text editor also fails, is still there in  FS#7785  , secondly the new builds, svn 14735, do not hang that much, or durin playback , they just hang sometimes while shutting down, the screen freezes on "shutting down", playback works smooth, resume works smooth, playing new tracks works perfect.
Comment by Przemysław Hołubowski (p.h.) - Monday, 17 September 2007, 20:06 GMT
Have you tried loading M3U playlists using recent builds?
Comment by Nikkhil (AceNik) - Monday, 17 September 2007, 20:09 GMT
yes loading .m3u playlist works fine in one go, just the player now hangs on "shutting down"
Comment by Przemysław Hołubowski (p.h.) - Monday, 17 September 2007, 20:16 GMT
Hanging on "shutting down" has happened from time to time on various revisions. Sometimes it was sufficient to leave H10 over a night with RB started, but not playing, to charge and then try to shut it down.

Loading...