Rockbox

Tasklist

FS#7744 - Leaving Mazezam Idle causes shutdown.

Attached to Project: Rockbox
Opened by Jack Suter (chrisjs169) - Monday, 10 September 2007, 03:51 GMT
Last edited by Marc Guay (Marc_Guay) - Friday, 11 July 2008, 00:15 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If you begin a game of mazezam on the Sansa (other targets unknown) and go to the quit menu, but leave it idle (don't select anything) it shuts down within about ten or 15 seconds. Rockbox doesn't have the "shutting down.." message so it could be possible that it's somehow registering the power button as being held.
This task depends upon

Closed by  Marc Guay (Marc_Guay)
Friday, 11 July 2008, 00:15 GMT
Reason for closing:  Invalid
Additional comments about closing:  New version works fine.
Comment by Peter D'Hoye (petur) - Monday, 10 September 2007, 22:14 GMT
No problem on my iriver and on the sim, so this may be target specific.
I see nothing special in the code either.

I guess that what you see after 15 seconds is the backlight going out, are you sure it is switching off?
Comment by Peter D'Hoye (petur) - Monday, 10 September 2007, 22:17 GMT
Heh... I write this comment and 1 minute later I see it happening :)
I did have to press some keys in the quit menu for it to happen though, just entering it and not touching anything does nothing.
Comment by Peter D'Hoye (petur) - Monday, 10 September 2007, 22:56 GMT
I changed the code to keep the backlight on while in the game, maybe something gets sprinted on the screen before it shuts down?

I am again not able to reproduce, very strange :/
Comment by Malcolm Tyrrell (Malcohol) - Friday, 28 March 2008, 17:18 GMT
I've given it a try, but I'm not able to reproduce this bug. I'm using a Sansa C250 with an untouched rockbox build: Rockbox r16850-080327.
Comment by Malcolm Tyrrell (Malcohol) - Monday, 07 April 2008, 20:39 GMT
I've changed lots of MazezaM in  FS#8861 . If possible, can someone confirm whether this bug is still a problem? (I was never able to reproduce it).
Comment by Malcolm Tyrrell (Malcohol) - Friday, 11 April 2008, 10:26 GMT
A new version of MazezaM is in SVN. Can someone confirm whether this bug still applies?
Comment by Marc Guay (Marc_Guay) - Friday, 11 April 2008, 12:47 GMT
Cannot reproduce on the e200 w/ 17071. I did notice however that you cannot return to the MazezaM main menu from the Audio playback menu, both "left" and "power" take you back to the game itself.
Comment by Malcolm Tyrrell (Malcohol) - Friday, 11 April 2008, 18:10 GMT
Here's a patch which solves the playback menu issue.

Loading...