Rockbox

Tasklist

FS#8144 - FM Tuner doesn't work on iRiver H10

Attached to Project: Rockbox
Opened by Sega (Sega) - Tuesday, 13 November 2007, 03:29 GMT
Last edited by Steve Bavin (pondlife) - Thursday, 20 March 2008, 09:42 GMT
Task Type Bugs
Category FM Tuner
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Although it was recently implimented into Rockbox, the FM Tuner does not work on my iRiver H10 20gb.

There is no reception, and when I go to scan for channels, it gets half-way through and then the iRiver freezes. I then have to do a hard reset of the device in order to make the device functional again.
This task depends upon

Closed by  Steve Bavin (pondlife)
Thursday, 20 March 2008, 09:42 GMT
Reason for closing:  Fixed
Comment by Przemysław Hołubowski (p.h.) - Tuesday, 13 November 2007, 10:28 GMT
My friend have experienced the issue too.

You could try to mannually search for a channel. It should give you proper reception.

Try to edit ./rockbox/fmpresets/preset01.fmr You can find there a list of radio channels in a format:
<frequency in Hz>:<channel name> for example:
99900000:Trojka
This adds radio channel called "Trojka" which frequency is 99,9MHz.

Enter all channels that you can recieve, load preset (long hold "o" button in radio mode). After that select a station from the list. If all you can hear is noise press "left" button to change mode from preset to search and using FF/REW mannually change frequency a bit to "catch" proper reception. Once you catch it you would be able to enter preset mode again and choose one from among your channels which recieve properly.

In case of my friend it helped. Radio channel frequency was shifted 0,1-0,3MHz. Mannual change of a frequency helped to catch reception, and then he was able to use preset frequency values.

Hope this helps.
Comment by Nikkhil (AceNik) - Thursday, 29 November 2007, 18:43 GMT
well i applied a field strength (shows signal strength) patch to my builds, n figured this out, when i tuned into a frequency with 9dBvf or so it hangs, do try it out, otherwise above that value all frequencies work well
Comment by Przemysław Hołubowski (p.h.) - Monday, 03 December 2007, 11:55 GMT
Try to apply a patch from  FS#8238  it may help you.
Comment by Nils Wallménius (nls) - Wednesday, 19 March 2008, 21:55 GMT
Is this still an issue with a current build?
Comment by Przemysław Hołubowski (p.h.) - Thursday, 20 March 2008, 08:35 GMT
No. It was fixed by  FS#8238 . I think this task should be closed now.

Loading...