Rockbox

Tasklist

FS#8160 - skip back after resume fails to play the song again

Attached to Project: Rockbox
Opened by Peter D'Hoye (petur) - Thursday, 15 November 2007, 09:03 GMT
Last edited by Nicolas Pennequin (nicolas_p) - Monday, 26 November 2007, 21:07 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System SW-codec
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

To reproduce:

- Be at about 10 seconds from the end of a song
- Stop and powerdown
- power up and resume playback
- skip back to start the song again

after some seconds playback skips to the next song automagically
This task depends upon

Closed by  Nicolas Pennequin (nicolas_p)
Monday, 26 November 2007, 21:07 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#8092 
Comment by Nicolas Pennequin (nicolas_p) - Thursday, 15 November 2007, 09:10 GMT
This looks like a duplicate of  FS#8092  to me.
Comment by Peter D'Hoye (petur) - Thursday, 15 November 2007, 09:20 GMT
I did look at it before submitting this one, but went ahead anyway because it talks about seeks, not a plain skip back.

If it is a dupe, it just shows I know nothing of playback/buffering. I added 8092 as related task....
Comment by Brandon Low (lostlogic) - Thursday, 15 November 2007, 22:12 GMT
I think this is a dupe of an even older bug having to do with _seek_ behavior when the codec has finished but the pcm buffer is full.
Comment by Adam Gashlin (AdamGashlin) - Tuesday, 20 November 2007, 18:49 GMT
I'm experiencing this, too, just a little more detail.
to reproduce (with 15722)
-play an MP3 (FLAC seems to work, too) for a while, stop
-resume
-after the buffer has been filled, skip back to the beginning of the track
-Track won't play to the end.

The time it stops before the end seems to be approximately the same as the time elapsed when the initial stop was done.
As noted, both FLAC and MP3 have this problem, MP3 will just go on to the next track while FLAC will get stuck playing a sample repeatedly at the breaking point.
AAC seems to be immune.
Comment by Nicolas Pennequin (nicolas_p) - Monday, 26 November 2007, 21:06 GMT
From the reproduction recipes, I'm 99% sure this is a duplicate of  FS#8092 . I'm committing a fix for  FS#8092 , so reopen this if the fix didn't solve the problem described above.

Loading...