Rockbox

Tasklist

FS#8449 - Track time not updating during pause fade

Attached to Project: Rockbox
Opened by Nate Rowe (Spanky) - Saturday, 12 January 2008, 06:49 GMT
Last edited by Jonathan Gordon (jdgordon) - Sunday, 15 June 2008, 11:23 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have the fade in/out option enabled on my iPod 4G Color and when I press play or pause the track time does not update on the wps. This only happens during the fade in/out sequence, so sometimes the time (in seconds) will jump ahead 2 seconds to catch up to the current and accurate time into the track.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Sunday, 15 June 2008, 11:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in 17723.
Comment by Steve Bavin (pondlife) - Tuesday, 11 March 2008, 07:24 GMT
I think this behaviour is as intended. What do you expect to see?
Comment by Nate Rowe (Spanky) - Tuesday, 11 March 2008, 20:25 GMT
I would expect to see the time continue updating, even when the song is fading. This isn't a super bad bug or even a bug really it's just something that I noted.
Comment by Nate Rowe (Spanky) - Monday, 17 March 2008, 18:36 GMT
Actually, I just realized that nothing on the screen updates, the songs quit scrolling and the time at the top of my custom wps stops and then jumps ahead 2 seconds. So basically, while the fade function is happening, the screen doesn't refresh information.

Loading...