Rockbox

Tasklist

FS#8563 - Some bookmarked files resume from start and can freeze player

Attached to Project: Rockbox
Opened by Philip Macpherson (crazybus) - Thursday, 07 February 2008, 13:15 GMT
Last edited by Steve Bavin (pondlife) - Monday, 10 March 2008, 17:48 GMT
Task Type Bugs
Category Playlists
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

For the most part bookmarks have worked for me but on a couple of files I've had trouble. This has being with both ogg's and mp3's and involves the file saving the bookmark time correctly but not resuming properly. For instance a certain file doesn't play from the bookmarked point but if you stop it and try again it might work. Other times doing that will not help and it will just always resume from the very beginning of the file. I've also try restarting the bookmark or another bookmark while the current file is still playing. That often causes the player to freeze. Anywhere from around 7 seconds of unresponsiveness (everything on the screen still moves like normal but the keys are unresponsive) to up to 12 minutes (after which I did a hard poweroff)

One of the files I have trouble with also has another problem. If it starts from the beginning when resumed from a bookmark you can't fast forward it. The file just keeps on playing while your finger is on the button and the time is going up. And when you release the FF button the timer goes right back to where it was.

I can repeat this by deleting the bookmark file. Playing Cory_Doctorow_Podcast_102_The_Hacker_Crackdown_Part_017.ogg fast forwarding, stopping to save a bookmark and then going to recent bookmarks to resume it.

This is using a recent vanilla build.
*Bookmarking on stop: Yes
*Load last bookmark: No
*Maintain a list of recent bookmarks: Yes

Attached is a id3 description of one of the files with the problem

P.S.  FS#8215  is similar but I'm opening this one because of some differences and the mentioned fix (rewinding) not working.
This task depends upon

Closed by  Steve Bavin (pondlife)
Monday, 10 March 2008, 17:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  I'll take your word for it.
Comment by leslie carver (nsolo11) - Monday, 11 February 2008, 16:19 GMT
I have this problem too including 11 Feb 2008 build. This has been at least since 2 Feb 2008 -- I have to revert to a January build to get my bookmarks working again.
Comment by Marc Guay (Marc_Guay) - Wednesday, 13 February 2008, 21:54 GMT
Not having this problem with identical settings on Sansa e200 & r16290, but switching directly from one bookmark to another without stopping playback causes the new bookmark to load and then stop immediately.
Comment by Marc Guay (Marc_Guay) - Thursday, 14 February 2008, 12:24 GMT
(FLAC & CBR MP3 Tested)
Comment by Marc Guay (Marc_Guay) - Monday, 10 March 2008, 17:45 GMT
I believe this has been fixed along with all of the other recent bookmarking bugs.

Loading...