Rockbox

Tasklist

FS#8748 - Freeze when selecting song from filetree in partymode

Attached to Project: Rockbox
Opened by PaulJam (PaulJam) - Monday, 17 March 2008, 11:36 GMT
Last edited by Jonathan Gordon (jdgordon) - Tuesday, 19 August 2008, 11:55 GMT
Task Type Bugs
Category Applications
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When playback is stopped and partymode is enabled it can happen that rockbox freezes shortly after you select a song from the filetree.

Reproduction:
Enable dircache (i wasn't able to reproduce it without dircache), then start playback and enable partymode. Now shutdown the device, restart it and then select a song from the filetree without starting playback first. It shows a splash with "queue last" and then freezes 2 seconds or so later (the disk continues spinning).

H300 with r16685 (default settings except for dircache and partymode)
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Tuesday, 19 August 2008, 11:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  partymode is ignored if nothing is playing
Comment by Marc Guay (Marc_Guay) - Tuesday, 01 April 2008, 01:57 GMT
Sansa e200 w/ r16899:

Without dircache enabled following the reproduction steps does not lead me to a freeze, but the cabbiev2 WPS displays "2 of 1" on the bottom, which could be an indication of what's going wrong here. The playlist shows the song has been queued, and if I try to play/select it, the icon changes to suggest it is now-playing, but the song does not play. The track display updates to the correct "1 of 1" but the ID3 info is not read/displayed.

With dircache enabled the "Queue Last" message is displayed and the player freezes a few seconds later. If I press play/pause before it freezes, the message "Nothing to Resume" appears.
Comment by Marc Guay (Marc_Guay) - Sunday, 13 July 2008, 00:28 GMT
The first bug I mentionned no longer seems to happen, but the second does. e200 & r18013.

Loading...