Rockbox

Tasklist

FS#9610 - no display visible on 2nd generation ipod

Attached to Project: Rockbox
Opened by Steve Morris (morris) - Sunday, 07 December 2008, 21:54 GMT
Last edited by Dominik Riebeling (bluebrother) - Sunday, 05 June 2011, 09:39 GMT
Task Type Bugs
Category LCD
Status Closed
Assigned To No-one
Operating System iPod 1G/2G
Severity Low
Priority Normal
Reported Version Release 3.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

no display visible on 2nd generation ipod

I have installed the following:
ipod1g2g-20081207-english.zip
rockbox-fonts.zip
rockbox-ipod1g2g-3.0.zip

The system boots to a blank screen. I have tried both
contrast:63 and contrast: 44 in config.cfg

I am able to hear the voice speaking the menu selections.

Holding down the stop button for a moment says
'shutting down' but the system reboots into the same
condition.

This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Sunday, 05 June 2011, 09:39 GMT
Reason for closing:  Out of Date
Additional comments about closing:  No activity for over 2 years. If this is still an issue with a current version of Rockbox please open a new task, otherwise considering this issue fixed.
Comment by Paul Louden (Llorean) - Sunday, 07 December 2008, 22:02 GMT
Have you also tried a current build at all?
Comment by Steve Morris (morris) - Sunday, 07 December 2008, 22:35 GMT
just tried r19360-081207 with the same results.
Comment by Alex Meyer (binaryhermit) - Sunday, 07 December 2008, 22:44 GMT
Does your display work in the OF?
Comment by Mark Fawcus (yapper) - Sunday, 07 December 2008, 22:51 GMT
The problem doesn't appear to be build related. Mine is still working fine with R19360-081207. I also removed the bootloader, and re-installed the current bootloader using Rockbox util - the iPod still works fine.
Comment by Steve Morris (morris) - Sunday, 07 December 2008, 23:03 GMT
the display works fine with original software. Also I see the apple on boot then it goes to a blank screen.
I've managed to move around the menus some using the voice prompts and other things are woring. filled the database and heard some mp3 files.
Comment by Steve Morris (morris) - Sunday, 07 December 2008, 23:04 GMT
the display works fine with original software. Also I see the apple on boot then it goes to a blank screen.
I've managed to move around the menus some using the voice prompts and other things are working. filled the database and heard some mp3 files.
Comment by Mark Fawcus (yapper) - Monday, 08 December 2008, 00:01 GMT
I've spotted a difference in behaviour when using the old (v2) bootloader and the current one, but in my case it shows up when booting into the OF, and does NOT affect the contrast when booting into Rockbox.

With the V2 bootloader, the OF contrast is good, but with the new bootloader I can hardly read the OF display (until I adjust the contrast).
Comment by Mark Fawcus (yapper) - Monday, 08 December 2008, 00:02 GMT
The problem doesn't appear to be build related. Mine is still working fine with R19360-081207. I also removed the bootloader, and re-installed the current bootloader using Rockbox util - the iPod still works fine.
Comment by Steve Morris (morris) - Monday, 08 December 2008, 23:24 GMT
I installed the bootloader by running ipodpatcher. Is there a separate bootloader I should try and install?
Comment by Mark Fawcus (yapper) - Tuesday, 09 December 2008, 01:45 GMT
Installing the bootloader via ipodpatcher is correct. But you might want to uninstall the V3.0 boot loader (by running ipodpatcher again and selecting the appropriate option), then try downloading the older version of ipodpatcher from here http://download.rockbox.org/bootloader/ipod/2.0/ipodpatcher/ to install the v2.0 bootloader.
Comment by Steve Morris (morris) - Tuesday, 09 December 2008, 19:49 GMT
I tried that with no change.
Comment by Jonathan Gordon (jdgordon) - Thursday, 17 December 2009, 23:22 GMT
did you have any luck getting it going?

Loading...