Rockbox

Tasklist

FS#9803 - Conflict between Car Adapter Mode and First Buttonpress Enables Backlight Only

Attached to Project: Rockbox
Opened by Eric Jorgensen (EricJorgensen) - Thursday, 15 January 2009, 17:10 GMT
Last edited by Frank Gevaerts (fg) - Friday, 22 January 2010, 21:00 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Gigabeat F/X
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Build R19503_081220 on Gigabeat F.

With both "Car Adapter Mode" and "First Buttonpress Enables Backlight Only" enabled, if the gigabeat is booted on battery power and then DC power is applied, the "first buttonpress" functionality persists even though the backlight is always on - the first buttonpress after the (now cancelled) backlight timeout is just thrown away.

If i power up the gigabeat with DC already applied, it behaves normally.
This task depends upon

Closed by  Frank Gevaerts (fg)
Friday, 22 January 2010, 21:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  Reported as fixed
Comment by Eric Jorgensen (EricJorgensen) - Thursday, 15 January 2009, 17:26 GMT
I should have said, the issue is with the "backlight (while plugged in)" feature. Which i confused with car adapter mode.

"backlight (while plugged in)" is set to "on" but if i power up the gigabeat w/o external power, use it for some time, then plug it in, i find that i lose the first buttonpress. If i plug it in, then power it up, i don't lose button presses.
Comment by Eric Jorgensen (EricJorgensen) - Thursday, 15 January 2009, 18:17 GMT
Having updated to a 3.1 build with a tweaked button map (seriously, play/pause on "A"? I understand why page scrolling had to move, but . . . . ) I can't seem to replicate this anymore.

Loading...