Rockbox

Tasklist

FS#10016 - v1 tag not read if v2 tag present regardless of content

Attached to Project: Rockbox
Opened by Jonas Häggqvist (rasher) - Thursday, 12 March 2009, 22:33 GMT
Last edited by MichaelGiacomelli (saratoga) - Tuesday, 26 July 2011, 19:01 GMT
Task Type Bugs
Category ID3 / meta data
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Version 3.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Rockbox doesn't read the tags of this file.

It contains the following tags:

ID3v1 tag
Title: Now Get Busy
Artist: Beastie Boys
Album: The Wired CD
Year: 2004
Track: 1
Genre: Hip-Hop
ID3v2.4.0 tag
replaygain_album_gain (TXXX): -7.62 dB
replaygain_album_peak (TXXX): 1.278176665
replaygain_track_peak (TXXX): 1.033416986
replaygain_track_gain (TXXX): -8.38 dB

However, Rockbox only reads the v2 tag, never bothering to check for the artist, title, album etc tag in the v1 tag.

Track is licensed CC-NC-Sampling+ 1.0 and copyright Beastie Boys, obviously.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Tuesday, 26 July 2011, 19:01 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Since it was decided that we didn't want to merge different tags into one metadata entry for a given file, this isn't actually a bug. Its just a file with broken tags.
Comment by Jonathan Gordon (jdgordon) - Wednesday, 16 December 2009, 08:58 GMT
I remember the argument but not the outcome... do you remember what was decided?
Comment by Rui Araújo (Akur) - Thursday, 11 February 2010, 01:29 GMT
Shouldn't Rockbox fetch the v1 tag if the v2 tag is empty?
Comment by Andree Buschmann (Buschel) - Saturday, 13 March 2010, 09:11 GMT
This patch checks whether there has been metadata (artist, title, album) read from the id3v2 tag. If not, it will try to read this information from the id3v1 tag.
Comment by Andree Buschmann (Buschel) - Sunday, 14 March 2010, 16:30 GMT
It is agreed not to support mixed tags in rockbox. Therefor this patch will not be added to svn.
Comment by Frank Gevaerts (fg) - Sunday, 14 March 2010, 22:54 GMT
For the record, I think that if all relevant tags are missing in v2, reading v1 is reasonable. The set of relevant tags should then at least include title and artist, but possibly also album and genre.

Loading...