Rockbox

Tasklist

FS#10075 - FUZE: QUIT Plugin by selecting BUTTON_HOME

Attached to Project: Rockbox
Opened by Johannes Schwarz (Ubuntuxer) - Monday, 30 March 2009, 18:42 GMT
Last edited by Thomas Martitz (kugel.) - Friday, 10 April 2009, 17:29 GMT
Task Type Patches
Category User Interface
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Version 3.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

It makes more sense to use BUTTON_HOME instead of the current BUTTON_POWER to quit a plugin, because BUTTON_POWER is alongside the player. In the orginal firmware the button is also just scheduled for switch off.

In the following week I'll write a patch for the plugins.
This task depends upon

Closed by  Thomas Martitz (kugel.)
Friday, 10 April 2009, 17:29 GMT
Reason for closing:  Accepted
Additional comments about closing:  Committed in r20680. Thank you!
Comment by Johannes Schwarz (Ubuntuxer) - Tuesday, 31 March 2009, 12:53 GMT
I have written a patch, which changes the button in addition to the fuze also in the clip, because there's the same button. I haven't change the buttons in spacerocks, solitaire and blackjack, because the BUTTON_HOME is used for something else there. The problem is that this games doesn't have a menu, so key sequence of buttons are used to restart for example a game. This isn't very user friendly. It would be much better to have menu for this plugins. I think it wouldn't be much effort.
Comment by Rafaël Carré (funman) - Wednesday, 01 April 2009, 11:25 GMT
tested on clip : the behaviour is not consistent with the menu (power still exits the menu)
Comment by Johannes Schwarz (Ubuntuxer) - Thursday, 02 April 2009, 21:02 GMT
I have reworked the patch and deleted the changes on the buttons from the clip. I have tested it elaborately, so it should work well, now.
Comment by Johannes Schwarz (Ubuntuxer) - Thursday, 02 April 2009, 21:51 GMT
I changed the menu button, so you have to press long. (BUTTON_REPEAT)

Loading...