Rockbox

Tasklist

FS#10098 - The list screen does not change when "select" button pressed after "hold" is released.

Attached to Project: Rockbox
Opened by Yoshihisa Uchida (Uchida) - Sunday, 05 April 2009, 12:23 GMT
Last edited by Boris Gjenero (dreamlayers) - Wednesday, 08 April 2009, 13:17 GMT
Task Type Bugs
Category Drivers
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Even if "select" button is pressed after "hold" is released, the list screen does not change.

The screen changes by pushing the "select" button several times.

The screen might not change when the lock is released while keeping pushing "select" button while lock the key.

I send this problem's patch.
Because this is too hacky, there is a possibility of not operating well.
And for other clickwheel iPods (iPod 4G, Photo/Color, mini 2G...),
I am not confirming operation.

Report please.
This task depends upon

Closed by  Boris Gjenero (dreamlayers)
Wednesday, 08 April 2009, 13:17 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Duplicate of FS#5230
Comment by Boris Gjenero (dreamlayers) - Wednesday, 08 April 2009, 05:10 GMT
This is a duplicate of FS#5230. I created a different patch for this problem:
http://www.rockbox.org/tracker/task/5230#comment29590

I also observed the weird values read from 0x7000c140. Based on data I collected, I don't think that the following lines in your patch catch all of them:
int v = (unsigned)status >> 4;
if ((v == 0xfffffff) || (v == 0x5555555) || (v == 0xaaaaaaa))
For example, I got 0xAAAAA7FE.

I think (status & 0x800000FF) == 0x8000003A only happens when a command is sent to the clickwheel to read a register. It is the response with the register value. The Wheel ID test in 5G iPod diagnostics shows the contents of registers 0 through 5. (It would be interesting to see if the contents of these registers are useful for Rockbox.)
Comment by Yoshihisa Uchida (Uchida) - Wednesday, 08 April 2009, 10:59 GMT
comment thanks.

It is the same bug as FS#5230.
But I cannot close this task. Someone, please close this task.

My patch is based on iPodLinux: /apps/ipod/ipodloader2/keypad.c.
Because my patch made while trying and erring, I think it is too unreliable.

Your made patch file will be confirmed.

Loading...