Rockbox

Tasklist

FS#10105 - *PANIC* event line full

Attached to Project: Rockbox
Opened by PaulJam (PaulJam) - Wednesday, 08 April 2009, 12:32 GMT
Last edited by Thomas Martitz (kugel.) - Wednesday, 08 April 2009, 17:00 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Reproduction:
Enable the settings "Gather Runtime Data" (DB probably needs to be initialized) and "Last.fm Log" (reboot if necessary).
Start playing a folder, go back to the browser and insert a song (via contextmenu => playlist => insert) then enter the WPS and skip forwards 2 times (so track 3 is playing).
Now change the volume and then enter the main menu. Then the player should panic immediately.

The problem seems to happen since r20633 (can't reproduce with r20632).

A similar problem was fixed in r17632 by increasing MAX_SYS_EVENTS, so maybe the same fix applies here too.

H300 with r20656 and default settings (except "Gather Runtime Data" and "Last.fm Log")
This task depends upon

Closed by  Thomas Martitz (kugel.)
Wednesday, 08 April 2009, 17:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  Committed fix in r20660

Loading...