Rockbox

Tasklist

FS#10211 - Calculator does not clean screen well

Attached to Project: Rockbox
Opened by Tomer Shalev (tomers) - Saturday, 16 May 2009, 08:58 GMT
Last edited by Steve Gotthardt (gotthardt) - Tuesday, 26 May 2009, 19:41 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To Steve Gotthardt (gotthardt)
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

To reproduce:
Open calculator
Press 9
Press 1/x twice

You'll notice leftovers from the last result 0.11111111, which are the lower pixels of the first four ("0.11") characters.

See screenshots.
This task depends upon

Closed by  Steve Gotthardt (gotthardt)
Tuesday, 26 May 2009, 19:41 GMT
Reason for closing:  Fixed
Comment by Dominik Riebeling (bluebrother) - Saturday, 16 May 2009, 12:55 GMT
I could reproduce this issue on e200 with default theme but *not* on c200 with default cabbiev2 theme. On h100 I've seen it using zezayer theme but *not* using cabbiev2. So this issue seems to be related to the font chosen.

Please add information about the test environment to a task in the first place. It's hard to guess what target you are using and it's quite annoying to have to dig for information that the reporter could have added in the first place. Of course the first target / theme combination I tried did not show the issue.
Comment by Steve Gotthardt (gotthardt) - Friday, 22 May 2009, 03:47 GMT
In the code REC_HEIGHT is calculated and could be too small due to rounding.
This is repeated subtracted from the Yoffset leaving the last offset too large.
When the clearing is done it used REC_HEIGHT which can be too small (depending on LCD_HEIGHT). This clears an area too small.
The solution is to clear the area based on the area's height: Y_1_POS.
Tested on Gigabeat.

Loading...