Rockbox

Tasklist

FS#10261 - context menu doesnt wait for unpress before checking for buttons....

Attached to Project: Rockbox
Opened by Jonathan Gordon (jdgordon) - Friday, 29 May 2009, 03:27 GMT
Last edited by Jonathan Gordon (jdgordon) - Sunday, 31 May 2009, 05:48 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To Jonathan Gordon (jdgordon)
Operating System All players
Severity Low
Priority Normal
Reported Version Version 3.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

hold down select on the "files" in main menu, it will jump straight to the setting context menu (because the first option in the files context menu is a valid quickscreen item...)

should be a simple fix... just need to get do_menu() to wait for a BUTTON_REL before checking for buttons... although more likely a proper fix is needed in action.c somewhere....
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Sunday, 31 May 2009, 05:48 GMT
Reason for closing:  Fixed
Comment by Thomas Martitz (kugel.) - Friday, 29 May 2009, 05:42 GMT
I cannot reproduce it on any of my players. Maybe it's just a keymap issue?
Comment by Jonathan Gordon (jdgordon) - Sunday, 31 May 2009, 05:15 GMT
could be... happens on ipod

Loading...