Rockbox

Tasklist

FS#10376 - Undefined instruction at 03E80478 (0) after playing an ogg file.

Attached to Project: Rockbox
Opened by Simon Prosser (simonprosser) - Tuesday, 23 June 2009, 17:53 GMT
Last edited by Dave Hooper (stripwax) - Saturday, 03 October 2009, 18:02 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Version 3.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

HW: iPod 5.5 Gen 60GB
Bootloader: ?? how can i check?
Build: 3.2-090323

Problem: Undefined instruction at 03E80478 (0) after playing an ogg file.

What I did:
1. Used iTunes to install mp3s.
2. Then I used rockbox installer.
-------I was able to play mp3s no problem.--------
3. Then I put ogg files on and tried to play (via file browser), then I got the undefined instruction.
4. After this i boot up into rockbox again and still get it for mp3s now.

Please let me know how to provide the information required to fix this bug. I can probably get my hands on a serial cable if you need me to hook it up to putty. This is 100% reproducible. Let me know how to provide the right information to fix the bug and I will. Can I get an old build from anywhere that still works?

This time I reinstalled rockbox on a player without ogg files, then I tried a few times (before putting oggs on it) and am getting Undefined instruction at:
03E80974 (0) -> this happens on any file that media money converted from ogg to mp3 (160kbps vbr). (this happened twice).
03E80478 (0) -> this happened with a Q5 ogg file i dragged onto the device (connected to vista with rockbox bootloader).
03E804D0 (0) -> this happened with a Q5 ogg file i dragged onto the device (connected to vista with rockbox bootloader).
03E8097C (0) -> not sure if this is ogg or mp3.
03E804D4 (0) -> not sure if this is ogg or mp3.

This doesn't happen on my iriver H340.
This task depends upon

Closed by  Dave Hooper (stripwax)
Saturday, 03 October 2009, 18:02 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Most likely fixed when a recent crash fix got committed, not enough information to reproduce
Comment by Dominik Riebeling (bluebrother) - Monday, 29 June 2009, 09:16 GMT
Please check if installing the 5.5G 30GB build "fixes" this.
Comment by Dave Hooper (stripwax) - Wednesday, 08 July 2009, 12:55 GMT
Is the bug apparent in versions prior to r20783 (which incorporated a number of libtremor changes) ?
Comment by Dave Hooper (stripwax) - Saturday, 03 October 2009, 18:02 GMT
Closing due to lack of response and recent tremor crash bugfixes that probably fixed this issue also

Loading...