Rockbox

Tasklist

FS#10380 - rbutil - wrong tool version on build

Attached to Project: Rockbox
Opened by Jens Erdmann (pyro_maniac) - Wednesday, 24 June 2009, 19:25 GMT
Last edited by Dominik Riebeling (bluebrother) - Monday, 29 June 2009, 09:24 GMT
Task Type Bugs
Category Rbutil
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Version 3.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

On some distributions qmake and lrelease are in the version 3.3.8 ( Kubuntu 9.04 for example) and the "right" tools are named qmake-qt4 and lrelease-qt4.

make uses lrelease and in this case the wrong version. This raises an error because the qt 3 version of lrelease has no "-silent" option.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Monday, 29 June 2009, 09:24 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  If your Qt installation reports the wrong path for QT_INSTALL_BINS your Qt installation is broken. Nothing we can do anything about. All my Qt installations (multiple installations on Windows and Linux) report the correct value, and my main Qt installation also uses "qmake-qt4".

Kubuntu package issue, please report to the packagers.
Comment by Dominik Riebeling (bluebrother) - Thursday, 25 June 2009, 06:20 GMT
My system also has Qt4 installed as qmake-qt4 and lrelease-qt4 resp. qmake does put the absolute path to lrelease here, and qt4 does *also* provide a binary lrelease (without the -qt4 extension, as /usr/lib/qt4/bin/lrelease). So you're saying that Kubuntu does not provide this one? I consider this a Kubuntu issue -- if it would have been a problem with Qt picking the wrong version I would have never been able to build since the dependency on lrelease was added.

Also, it might be a good idea to discuss such issues on the mailing list first before adding bugs. It's definitely not rbutil's charge on how your toolchain is set up.
Comment by Dominik Wenger (Domonoky) - Thursday, 25 June 2009, 10:18 GMT
We discussed this in IRC.
Yes there is still a lrelease binary there but, the problem is, that his qmake-qt4 reports the wrong QT_INSTALL_BINS dir.

Loading...