Rockbox

Tasklist

FS#10412 - Playe plays loud static noise after resuming play after it was in stop mode

Attached to Project: Rockbox
Opened by Dark Madder (DarkMadness) - Tuesday, 07 July 2009, 10:14 GMT
Last edited by Jens Arnold (amiconn) - Sunday, 03 January 2010, 13:36 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iAudio X5
Severity Low
Priority Normal
Reported Version Version 3.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,
I have following problem. If I make player go in stop mode (little square is displayed instead of pause or play symbol) then when I resume playback only very laud static noise is played. This happens every time I hold play/pause button for long time, I start recording and then go back an resume playing or I connect USB port to pc and after disconnecting it I resume play. To stop this behavior after it has occurred I must restart rockbox.

I hope somebody can check this or give me some directions where to look in the code so perhaps I can make changes in the code myself.

Greetings!
This task depends upon

Closed by  Jens Arnold (amiconn)
Sunday, 03 January 2010, 13:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in r24164. Affected targets were iAudio X5, M5 and M3.
Comment by Dark Madder (DarkMadness) - Tuesday, 07 July 2009, 20:19 GMT
I have done some testing and I observed that this problem was caused by my particular equalizer setting. After loading default parameters this behavior didn't occur any more. But if I change bass or treble to any value other then 0 this problem starts occurring even with equalizer turned off.

I hope this helps to solve the problem.
Comment by Dave Hooper (stripwax) - Sunday, 12 July 2009, 12:05 GMT
Does this happen with all audio formats? Or just some specific ones? (which codec are you using).
Comment by Dark Madder (DarkMadness) - Monday, 13 July 2009, 01:28 GMT
When problem occurred I have used ogg vorbis codec. After you asked I have tested it with mp3 and FLAC files and behavior is the same with most of them, with some mp3 and wav files however this behavior is not occurring but if the problem happens one time after that it happens with all files.
Comment by Nicolas GIF (salokyn) - Sunday, 30 August 2009, 17:30 GMT
I have the same bug on my X5 too for many months (still in today's build). As you said, if bass & treble settings are set to 0, it does not happen anymore. I tried with Equalizer, it does nothing. Seems that only bass and treble settings are in cause.
Comment by Dave Hooper (stripwax) - Thursday, 26 November 2009, 12:14 GMT
Also reported in  FS#10768 .

Comment by Marko Pahlke (perfectdrug) - Monday, 16 November 2009, 12:54 GMT
yes it seems to be the same bug.
thanks, I look into the pre-cut setting.

Loading...