Rockbox

Tasklist

FS#10426 - Wrong sort when title has a number

Attached to Project: Rockbox
Opened by Benoit (benoit) - Friday, 10 July 2009, 15:36 GMT
Last edited by Dominik Riebeling (bluebrother) - Sunday, 05 June 2011, 11:24 GMT
Task Type Bugs
Category Database
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Low
Priority Normal
Reported Version Version 3.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello,

When a song title is a number like "17" or "1979", database navigation order is wrong.

Song "17" is shown "17. 17 - 00:17" (it lasts 17 seconds).
Song "1979" is shown "79. 1979 - 04:25".

If the song's title contains a number, the same thing happens.

Song "Hawkmoon 269" is shown "69. Hawkmoon 269 - 06:22".
Song "100,000 raisons" is shown "100,000 raisons - 03:42", without any prefix order number.

Of course, the order of the file in the list corresponds.

I only use Ogg files, without any track value in the tags. I did not modify the tagnavi.config.
This issue also occured with previous versions.

Regards,
Benoit
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Sunday, 05 June 2011, 11:24 GMT
Reason for closing:  Out of Date
Additional comments about closing:  No activity since 2 years. Guessing track numbers is likely to get removed soon anyway -- see mailing list for discussion.
Comment by Yoshihisa Uchida (Uchida) - Monday, 13 July 2009, 10:53 GMT
I confirmed this problem.

This problem happens when the tracknumber is not included in ID3 tag.

Please build Rockbox after applying this problem's patch file.
And change settings:
Settings > General Settings > Database > generate Tracknumber > selects "No".

And remake database newly.
Comment by Benoit (benoit) - Monday, 13 July 2009, 18:50 GMT
It would be more usable to generate a "fake" tracknumber in database from file order in directory, the same way files are displayed in directories when browsing.

It would be working for directories with files with tracknumbers in ID3, and for directories without tracknumbers in ID3. But we need a rule to determine numbers when mixing those two files types (with/without).
Comment by Steve Bavin (pondlife) - Monday, 20 July 2009, 09:11 GMT
I'd suggest thatr we don't generate fake track numbers at all - internally they should be track 0 and purely sorted on title.

Loading...