Rockbox

Tasklist

FS#10460 - Cuesheet problems with Viewport enabled WPS

Attached to Project: Rockbox
Opened by Michael Chicoine (mc2739) - Tuesday, 21 July 2009, 11:59 GMT
Last edited by Jonathan Gordon (jdgordon) - Thursday, 23 July 2009, 15:23 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r21991

While using cuesheet support on a WPS using viewports, the track name does not follow the cuesheet. Also, the track name and artist fields get corrupted shortly after playing through a cuesheet segment (screenshot attached). The failure does not occur on any of the built-in themes (they do not use viewports).

tested on e200v1 and e200v2 and e200sim
worked in r21977

Steps to reproduce:
1. Add a viewport enabled theme. I used widecabbie.
2. Boot and clear settings to default.
3. Switch to viewport enabled theme.
4. Enable cuesheet support and reboot.
5. Play a track with cuesheet. The cuesheet I used is attached.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Thursday, 23 July 2009, 15:23 GMT
Reason for closing:  Fixed
Comment by Michael Chicoine (mc2739) - Tuesday, 21 July 2009, 12:04 GMT
Additional note:

I did not see the track title and artist fields get corrupted on the simulator, only the actual target.
Comment by Marianne Arnold (pixelma) - Tuesday, 21 July 2009, 22:12 GMT
I did some testing as I suspected widecabbie to be at fault - on my c200 and with my WPS, cabbiev2 (which also draws to the main screen even though it uses viewports partially, same as widecabbie) and iCatcher.
Here's whatI found (paste from IRC so I don't have to type it again):

- on my c200 I get the following with cuesheet support: iCatcher which has no viewports works flawlessly, cabbiev2 which has viewports and draws progressbar and some images into the main screen has the update problem (disabling/commenting out the progress bar helps, stuffing things neatly away into own vps doesn't), my WPS crashes Rockbox (I guess it's because it uses 2 progressbars, conditionally)
- it crashed with an older build too though
- at one time I saw bogus info in the "next track" info with cabbiev2 after skipping to the next or previous subsong of the cuesheet but couldn't reproduce
- must be something else that causes the crashes with my WPS as I just added 2 more progressbars in differently long viewports to cabbiev2 and it didn't crash

If you want to I can give you my WPS and the edited cabbiev2 I worked with.
Comment by Jonathan Gordon (jdgordon) - Thursday, 23 July 2009, 05:27 GMT
I'm hoping 22012/3 fix this issue.... close if it does
Comment by Michael Chicoine (mc2739) - Thursday, 23 July 2009, 14:12 GMT
It appears to be fixed. Thanks!!

Loading...