Rockbox

Tasklist

FS#10479 - Changing system language stops playback

Attached to Project: Rockbox
Opened by Rosso Maltese (asettico) - Friday, 31 July 2009, 10:06 GMT
Last edited by Andree Buschmann (Buschel) - Sunday, 13 February 2011, 21:30 GMT
Task Type Bugs
Category Settings
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When playback is running and you select a different system language, the playback stops and the status bar reports the square icon "stop". Going to WPS, the playback restarts without re-buffering.
I can't tell if this is a needed behaviour, but it seems that in the past didn't occur.

Reported in r22088 onto iPod Video (other targets could be affected).

Simulator is also affected.
This task depends upon

Closed by  Andree Buschmann (Buschel)
Sunday, 13 February 2011, 21:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with r29300.
Comment by Jonas Häggqvist (rasher) - Friday, 31 July 2009, 10:32 GMT
If I understand correctly, stopping playback should only be necessary when loading a new voice file.

On top of that, playback should be resumed in any case.
Comment by Rosso Maltese (asettico) - Friday, 31 July 2009, 10:38 GMT
Correctly speaking, playback should be resumed if previously running. ;-)
Comment by Andree Buschmann (Buschel) - Sunday, 13 February 2011, 20:27 GMT
This fixes the playback stopping when loading a new language without using a voice file.

Loading...