Rockbox

Tasklist

FS#10504 - Make MPEG audio thread use correct sample count

Attached to Project: Rockbox
Opened by Jeffrey Goode (Blue_Dude) - Monday, 10 August 2009, 04:56 GMT
Last edited by Thomas Martitz (kugel.) - Wednesday, 12 August 2009, 18:30 GMT
Task Type Patches
Category Plugins
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Version 3.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Requires the plugin API changes in  FS#10502 .

Tweaks the mpeg audio thread to use the input and output count functions before the dsp_process function as intended. This makes sure dsp_process works correctly if resampling or other processes are active that may affect the sample count.
This task depends upon

Closed by  Thomas Martitz (kugel.)
Wednesday, 12 August 2009, 18:30 GMT
Reason for closing:  Accepted
Additional comments about closing:  Jeffrey committed it in r22280.

Loading...